Онлайн-редактор

Переклади здебільшого здійснюються в редакторі, який можна переглядати в режимі Зручний або Поруч. Як правило, увімкнено режим Зручний.

Using the Menu in the top left corner you can switch between files for translations, change translation language, contact manager, switch the view, get help or quit the editor.

Зручний режим

Зручний режим в основному використовується для перекладу і складається з чотирьох основних розділів:

  1. Ліва бічна панель
  2. Верхня середня область
  3. Нижня середня область
  4. Права бічна панель

Розділи редактора

Розділ 1 - Ліва бічна панель

У цьому розділі ви побачите список рядків, і активний рядок буде виділено. Рядки - це текстові елементи у вигляді окремих слів, виразів чи приказок. Деякі рядки можуть мати замінні маркери (наприклад, {0}, {1} ці %1) або елементи з Синтаксис повідомлення ICU. Такі об’єкти самі по собі не потребують перекладу, і вони використовуються кодом сайту для динамічного вставлення деякої інформації в рядки. Для роботи з такими рядками потрібно скопіювати оригінальний рядок і перекласти лише реальні слова.

Рядки можуть мати такі статуси:

  • Неперекладений - не має перекладу
  • Множинні форми неперекладені - частково перекладено (у випадку, якщо деякі форми множини не перекладені)
  • Перекладено - перекладено
  • Множинні форми неприйняті - частково затверджено (в разі, якщо деякі множинні форми ще не затверджені)
  • Затверджено - затверджено
  • Приховано - приховано (показується тільки керівникам і редакторам)

Крім рядків, можуть бути такі значки:

  • З коментарями - рядок містить коментарі учасників
  • З невирішеним питанням - рядок має невирішене питання

При перекладі вмісту з файлів HTML, XML, TXT, DOCX, HAML, Web XML та Markdown список рядків відображатиметься у вигляді попереднього перегляду файлів. Стани рядків позначаються такими кольорами:

  • Червоний - не перекладені
  • Світло-зелений - перекладені
  • Зелений - ухвалені
  • Сірий - не для перекладу

Активна лінія виділена жовтим кольором.

Перегляд HTML

Для управління наведеним поданням доступні наступні параметри:

  • Основний перегляд списку - завантажити основний перегляд списку. Використовуйте для переходу в звичайний режим і перегляд списку рядків.
  • Виділені рядки - виділяє неперекладені, перекладені та затверджені рядки. Використовуйте для вмикання/вимикання виділення кольорових рядків.
  • Попередній перегляд перекладу - показати попередній перегляд перекладу. Використовуйте, щоб увімкнути/вимкнути режим попереднього перегляду перекладу.

Параметри перегляду HTML

You can search for strings by source text, translations, context, or everything at once. Depending on the content you opened in the Editor, the system will look for matches within the particular opened file or all strings in the project.

To search for strings in the file or the whole project, type your search phrase in the Search in file (Search strings) field. You can also use a keyboard shortcut to switch to the search field (by default, Ctrl+F).

To fine-tune the search results, you can use the following options:

  • Match case – With this option, you will find only the strings written in the same case: for example, if you search for Work and select Match case, the system will find Work, Works, Working but not work.
  • Match whole phrase – With this option, you will find the strings that contain the search phrase only in the original order: for example, if you search for Machine Translation and select Match whole phrase, the system will find Machine Translation, Machine translation, machine translation but not Translation Machine. When Match whole phrase isn’t active, the system splits the search phrase into separate words and searches for matches in the strings in any order.
  • Exact match – With this option, you will find only the strings that exactly match the search phrase: for example, if you search for Work and select Exact match, the system will find Work, work, but not Works or Working.

You can combine Match case with Exact match and Match case with Match whole phrase. Match whole phrase and Exact match are mutually exclusive options.

The search phrase is limited to 128 characters. If you paste a search phrase greater than 128 characters, it will be automatically trimmed down to the maximum allowed limit.

String Search

Filtering Strings

To filter the strings displayed in the left sidebar, click and select the preferred filter option.

Available filter options:

  • Show All – Show all strings from the opened file/folder in the original order.
  • All, Untranslated First – Show all strings from the opened file/folder. Untranslated strings are displayed at the top of the list, then translated strings, and the approved ones are displayed at the bottom of the list.
  • Untranslated – Show only strings without any translations.
  • Need to Be Voted – Show already translated strings.
  • Not Approved – Show strings that are already translated but not yet approved by a proofreader.
  • Approved – Show only strings with approved translations.
  • QA issues – Show strings with no QA issues or with unresolved QA issues in the current language.
  • Machine Translation – Show strings that are translated by TM or MT suggestions without changes. Often such strings need additional review.
  • With Comments – Show strings that have comments.
  • With Unresolved Issues – Show strings with unresolved issues in the current language or all languages.
  • Hidden – Show strings that are hidden from translators. Strings can be hidden by project managers or hidden automatically by Crowdin when they are marked as duplicates.
  • Advanced Filter – Filter that allows configuring own filtering and sorting parameters.

Фільтр рядків

Verbal Expressions

The Verbal Expression section implements a regular expression search. You can set specific search parameters for strings in your project. For example, you can search for all strings that begin with capital letters and have no dots at the end or contain a date.

Note: When you enable verbal expressions, you cannot use regular string search.

For example, if you’d like to extract all strings that start with a capital letter and have a dot at the end, your expression might look like this: start, then "A,Z", anything, range "a,z,A,Z,0,9", limit "1,", then ".", end

Let’s break down the expression above:

start – indicates the beginning of the expression. then "A,Z" – means that your expression starts with characters ranging A-Z. range "a,z,A,Z,0,9" – means that your custom placeholder might include characters ranging a-z and/or A-Z and/or 0-9. limit "1," – means that the length of the expression is from 1 character. then "." – means that your expression ends with a dot. end – indicates the end of the expression.

To configure a verbal expression, use the following expression syntax.

Розділ 2 - Верхня середня область

Це основна робоча область із вихідним рядком вгорі та секцією перекладу внизу. Щоб додати переклад, потрібно вибрати рядок у лівій частині розділу, і він відображатиметься у верхньому центрі поля Джерело рядка.

Текст для перекладу

Ця область також показує контекст рядка. Контекст може містити технічні деталі, пояснення того, де буде знаходитися рядок у поточному продукті, або скріншот із зображенням розташування рядка в інтерфейсі користувача. Якщо у вихідного рядка немає контексту і незрозуміло, як його перекласти, натисніть Запит, і менеджеру проекту буде повідомлено, що потрібні додаткові пояснення.

Запит контексту

Деякі рядки можуть мати підкреслені слова чи вирази. Це означає, що слово або вираз належать до термінології проекту і повинні бути перекладені відповідно до опису терміна. Для точного перекладу можна використовувати додаткові пояснення до певного терміну. Це можна зробити, якщо навести курсор миші на підкреслений текст або перейти до розділу Терміни на правій бічній панелі.

Деякі терміни можуть мати переклади. Попередньо перекладені терміни підвищують узгодженість текстів у проекті. Для повторного використання перекладу терміна необхідно натиснути підкреслений термін, і його переклад з’явиться в полі перекладу.

Термінологія

Введіть переклад у поле під вихідним текстом у розділі центру та натисніть Зберегти. Ви будете автоматично переспрямовані до наступного рядка.

Зберегти переклад

Plural Forms

Деякі рядки можуть мати множинні форми. Залежно від мови кількість форм множини може змінюватися. Наприклад, китайська має одну форму множини, англійська - дві, а інші можуть мати до шести форм множини. Crowdin працює з формами множини згідно з правилами мови множини CLDR.

Детальніше про Правила множинних мов CLDR.

Якщо рядок має кілька форм множини, всі параметри рядків будуть показані в розділі, де ви вводите переклади. Введіть переклади у відповідні вкладки, де відображаються форми множини для цільової мови.

Множинні вкладки

Ви також можете застосувати автоматичний контроль якості (КЯ), щоб уникнути неточностей перекладу. Наприклад, ви можете бачити сповіщення про пунктуаційні невідповідності, пробіли, відсутні змінні тощо.

КЯ спливаючі вікна

Clicking icon in the top right allows you to:

  • Скопіювати URL-адресу рядка, щоб отримати доступ до певного рядка, використовуючи унікальне посилання, або надіслати його колезі.
  • доступ Історія перекладу, щоб побачити всі зміни, внесені до рядка. У вікні перекладу ви також побачите межу Максимальної довжини перекладу, якщо вона буде перевищена.

Розділ 2

Додаткові кнопки доступні в розділі перекладу:
Copy Source - Копіювати джерело. Використовуйте для збереження початкової структури рядків під час перекладу повідомлень за допомогою символів або символів синтаксису повідомлення ICU.
Очистити переклад - Очищення. Використовуйте, коли вам потрібно швидко стерти все речення.
Режим вибору тексту - Режим вибору тексту. За необхідності скопіюйте частину перекладів із пам’яті перекладу (ПП) або машинного перекладу (MП).

Розділ 3 - нижня середня область

Цей розділ містить ресурси, які можуть бути корисними:

  • Переклади інших учасників проекту
  • Пропозиції з пам’яті перекладів (ПП)
  • Машинний переклад (МП) пропозиції
  • Переклади іншими мовами

Натисніть на одне із речень, і воно автоматично з’явиться в полі перекладу. Зверніться до них як до основи для власних пропозицій.

To quickly copy the TM or MT suggestion to the translation field and save it, click Use and Save icon on the desired suggestion.

Розділ Інші мови дозволяє перевірити рядкові переклади на інші цільові мови. Це може бути корисною порадою для багатомовних людей та при перекладі на діалекти.

Інші мови

Якщо ви бачите, що у вже є правильна пропозиція, проголосуйте за неї. Для голосування за кілька перекладів зручніше перейти в режим Порівняльний.

Проголосувати

Якщо ви коректор і плануєте переглянути та затвердити кілька перекладів, перейдіть до режиму Порівняльний.

Розділ 4 - Права бічна панель

Коментарі

За допомогою вкладки Коментарі ви можете обговорити значення вихідного рядка або інші пов’язані з цим проблеми. Рекомендується використовувати мову джерела проекту, щоб інші перекладачі могли його зрозуміти. Використовуйте “@” та ім’я користувача, щоб надіслати повідомлення певній особі.

Коментарі

Reporting Issues

Additionally, in the Comments tab, you can report the issues regarding the source strings or translations to the project managers by selecting the Issue checkbox.

Available issue types:

  • General question – General question related to the source string or its translations.
  • Current translation is wrong – The translation added to the source string is incorrect and requires correction.
  • Lack of contextual information – The meaning of the string isn’t clear and requires additional clarifications.
  • Mistake in the source string – The source string text contains typos or any other mistakes.

All strings with unresolved issues could be filtered using the With Unresolved Issues options.

Read more about Filtering Strings.

Питання

The issues are reported to the project managers to correct mistakes or add context and resolve the issues. Ви також можете Редагувати, Вирішити або Видалити своє питання, натиснувши на нього.

Варіанти питання

If the project owner or managers configured the integration with Jira, all reported issues will be directed to the Jira dashboard for further processing and resolution without the need to visit Crowdin Editor.

Read more about Jira Integration.

Пошук у ПП

By going to the Search TM tab, you can check for all the available translations from Translation Memory that is the vault of translations uploaded to the system by project managers.

The Search TM tab provides the following options:

  • Source – Search for matches in a source language.
  • Target – Search for matches in target languages.
  • Guess translation – Highlight probable translation of a search phrase.
  • Numeric equivalence – Match digits from a search phrase with any other digits.

Additionally, to maximize your search results, you can use the following wildcards with your search phrase:

Type an asterisk (*) to find words where the end or beginning may be different. Example: any* finds any, anyway, anything Example: *way finds way, anyway, highway

Type a plus sign (+) to find words where the end or beginning must be different. Example: any+ finds anyway, anything, anywhere, except any Example: +way finds anyway, highway, someway, except way

Type a minus sign (-) to exclude words from your search. Example: Save -as

Use quotation marks to find the exact combination of words. Example: “Save as”

Пошук у ПП

Терміни

Вкладку Терміни можна використовувати для перегляду доступного словника, доступного для рядка (якщо такий є). You can also search for the terms in project glossary.  If the specific term is not available in the project’s glossary, the system will show you Wikipedia explanations.

Терміни

Порівняльний

Порівняльний режим, перекладачі також можуть перекладати, хоча цей режим здебільшого призначений для комфортного голосування за кілька кращих перекладів поспіль, тоді як менеджери та коректори можуть схвалити найкращі переклади.

To switch to the Side-by-Side mode, open the Menu in the top left corner then choose View > Side-by-Side.

Для перекладачів

Щоб проголосувати, натисніть на знак плюс , якщо вам подобається переклад, та знак мінус , якщо переклад здається невірним. Переклади, які отримають найбільш позитивні голоси, будуть розміщені у верхній частині всіх перекладів, доступних для рядка.

Режим голосування

Для коректорів

Review the translations to make sure they are ready for export and click Approve icon next to the suggestion to approve each translation separately.

Щоб затвердити всі або декілька рядків одночасно, встановіть прапорці зліва від них та натисніть Затвердити.

Режим корректури

Note: Make sure to enable QA checks to help you find strings that require review. Знайдені помилки будуть виділені червоним кольором під перекладеними рядками, які потребують перегляду.

Питання ПЯ

Запропоновані переклади

Щоб запропонувати інший переклад, натисніть на текст, який ви хочете змінити, і, зробивши це, натисніть Зберегти. Ваш переклад буде доданий до списку інших пропозицій.

Збереження пропозицій

Переклад на мови з написанням справа наліво

При перекладі між мовами зліва направо на мову з право наліво деякі елементи в полі перекладу в редакторі можуть не відображатися так, як це було зроблено після експорту.

Щоб переконатися, що переклади справа наліво відображаються правильно в експортованому файлі, радимо перекласти наступним чином:

  1. Click under the source text (or Alt+C key combination).
  2. Переведіть вихідні тексти на мову перекладу.
  3. Залиште змінні, теги тощо. жодних змін у перекладі, навіть якщо вони виглядають неправильно. У експортованому файлі вони будуть у правильних положеннях.

Збереження пропозицій

Налаштування редактора

To open the Editor settings, click in the right upper corner.

Налаштування

Налаштування редактора включають такі параметри:

  • Пропозиції щодо пам’яті перекладу – Ви можете вказати мінімальну відповідність (у відсотках) для пропозицій пам’яті перекладу, показаних у полі перекладу.
  • *Компактний перегляд рядків * –, якщо це ввімкнено, у списку рядків відображатимуться лише початок довгих рядків.
  • Перевірка якості – якщо це ввімкнено, спливаючі повідомлення з попередженнями з’являться щоразу, коли ви намагаєтесь зберегти переклад з будь-якою неточністю (невідповідність пунктуації/тегів/пробілів, пропуск змінних тощо)
    Валідатори

  • Автозавершення – якщо це увімкнено, під час введення перекладу з’явиться спливаюче вікно, яке автоматично намагається передбачити завершення перекладу.
  • Auto-approve – if enabled the translations added by proofreaders or members with higher permissions are automatically approved.
  • Відображення HTML-тегів – ви можете вибрати Показати або Приховати, що стосується всіх тегів HTML. Якщо вибрано Автоматично, теги в HTML, Haml, XML, Web XML, Markdown, Docx файли будуть приховані, але відображатимуться в інших форматах файлів. Наприклад, якщо теги приховані, ви можете очікувати, що:
    <a href="https://sample.com">Приклад</a>
    

    буде замінено на

    <0>Приклад</0>
    
  • Color Theme – set the Light or Dark theme, or select Auto to allow the Editor to set the theme based on your device system settings.
    Налаштування

Корисні поради

Гарячі клавіші

Використовуйте комбінації клавіш для швидкого виконання дій у редакторі. Перевірте список комбінацій клавіш, натиснувши на значок клавіатури у верхньому правому куті. Більшість гарячих клавіш можна налаштувати під ваші особисті пріоритети. Натисніть потрібну комбінацію клавіш і змініть її за допомогою клавіатури.

Гарячі клавіші

Легкий доступ до найбільш використовуваних пунктів меню одним натисканням миші:

  • Мова – натисніть на поточну мову (французька на скріншоті нижче)
  • Файли – натисніть на ім’я поточного файлу (impact.xml на скріншоті нижче)
    Швидкий доступ

Корисні варіанти вихідних слів

Щоб перевірити пропозиції з пам’яті перекладу для певного слова чи фрази, оберіть його у рядку джерела та виберіть у меню Пошук у ПП. Ви також можете шукати пояснення слова або фрази в термінології проекта та Вікіпедії.

Примітка:Параметр Створити термін у цьому розділі доступний лише менеджерам.

Пошук терміна

Перехід на інший файл

Щоб перекласти рядки з інших файлів, виконайте наступні дії:

  1. Open the Menu or click on the current file name in the top left corner.
  2. Оберіть Файл > Відкрити.
    Відкрити файл
  3. Оберіть потрібний файл і натисніть Відкрити. Ви також можете просто двічі клацнути на потрібний файл.
    Обрати файл

Щоб переглянути всі рядки проекту, скористайтеся Головне меню у верхньому лівому куті та перейдіть до: Файл > Всі рядки. Ви також можете натиснути на ім’я поточного файлу у верхньому лівому куті > Всі рядки.

Заміна в запропонованих перекладах

Ви можете легко знайти та замінити запропоновані переклади за допомогою функції Замінити в перекладах.

Щоб замінити раніше додані переклади новими, виконайте наступні дії:

  1. На сторінці проекту оберіть потрібну мову.
  2. Натисніть Всі рядки > Переклад або оберіть файл для перекладу.
  3. Open the Menu in the top left corner.
  4. Перейдіть: Файл > Заміна в перекладах.
    Заміна перекладів
  5. Вставте слово, фразу або речення, яке ви хочете замінити, і текст, який ви хочете замінити.
    Вставте текст
  6. НатиснітьПопередній перегляд, щоб знайти рядки, які потрібно замінити.
    Попередній перегляд
  7. Оберіть переклади, які ви хочете замінити, і натисніть Замінити обраний для завершення.

Розширений фільтр

You can create a custom filter of strings by clicking the Filter strings icon and choosing Advanced Filter option.
You can choose multiple filter parameters (e.g., strings added, strings updated, translations updated, Labels and more) based on your specific needs to sort the strings. Це допоможе вам знайти потрібну інформацію набагато швидше.

In the below screenshot, you may see the strings are filtered by Translations updated interval, the Labels that the filtered strings should be marked with, the Comments, Visibility, and Approved by parameters as well as sorted by Alphabet in Descending order. Розширений фільтр

Приховати контекст у режимі "Порівняльний"

Контекст відображається за замовчуванням. Щоб приховати контекст та іншу інформацію, наприклад, дату перекладу чи затвердження, авторів, використовують значок Інформація . Без будь-якого контексту рядки займають менше місця на екрані.

Приховати контекст

Завдання в редакторі

Після того, як перекладачеві чи коректору буде призначено завдання, усі деталі завдання будуть доступні в редакторі:

  1. Назва завдання відображається на верхній панелі інструментів.
  2. Фільтри та пошук стосуються лише певного завдання.
  3. Детальну інформацію про роботу можна отримати, натиснувши на меню у верхньому лівому куті.

Меню завдань складається з таких компонентів та функцій:

  • назва, дата створення, мова та тип завдання
  • параметри вивантаження та завантаження перекладів для певного завдання
  • можливість вийти з редактора певного завдання (кнопка “Вийти з редактора”) та повернутися до списку завдань Меню завдань

Ця стаття була корисною?