Online-redigeringsværktøj

Translations are mainly made in the Editor which can be viewed in Comfortable or Side-by-Side mode. Typically Comfortable mode is enabled.

Using the Menu in the top left corner you can switch between files for translations, change translation language, contact manager, switch the view, get help or quit the editor.

Comfortable Mode

Comfortable mode is mainly used for translations and consists of the four main sections:

  1. Left sidebar
  2. Middle-top area
  3. Middle-bottom area
  4. Right sidebar

Sektioner, Redigeringsværktøj

Section 1 - Left sidebar

In this section, you will see the list of strings, and the active one will be highlighted. Strenge er tekstelementer, som enten er enkelte ord, udtryk eller sætninger. Some strings might have replacement tokens (something like {0}, {1}, or %1) or elements of ICU message syntax. Such items themselves should not be translated but are used by the website code to insert some information into strings dynamically. For at behandle sådanne strenge, kopieres kildestrengen og kun de egentlige ord oversættes.

Strings may have the following statuses:

  • Untranslated - uoversat
  • Plural forms untranslated - delvist oversat (i tilfælde af at nogle af flertalsformer er uoversætte)
  • Translated - oversat
  • Plural forms unapproved - delvist oversat (i tilfælde af at nogle af flertalsformer ikke er godkendt)
  • Approved - godkendt
  • Hidden - skjult (kun synlig for projektadministratorer og korrekturlæsere)

There also might be the following icons besides strings:

  • With Comments - the string has comments from contributors
  • With Issue - the string has an unresolved issue

While translating the content of an HTML, XML, TXT, DOCX, HAML, Web XML, and Markdown file formats a list of strings is displayed as a file preview. Statuses of the strings are marked with the following colors:

  • Rød - uoversat
  • Lysegrøn - oversat
  • Grøn - godkendt
  • Grey - not for translation

An active string is highlighted with the yellow color.

HTML view

The following options are available to manage the above view:

  • Basic List View - load basic list view. Use to switch to a standard mode and see a list of strings.
  • Highlight Strings - highlight untranslated, translated, and approved strings. Use to turn on/off color highlight of strings.
  • Translation Preview - show translation preview. Use to turn on/off translations preview mode.

HTML view options

Clicking the Filter strings icon allows you to filter the strings the way you need. For example, you can filter out only untranslated strings, as shown in the screenshot below.

Strings filter

Section 2 - Middle-top area

The main working area with the source string on the top and translation section below. To add a translation, you need to choose the string from the left section, and it will appear in the central top field Source String.

Tekst til oversættelse

This area also shows the context of a string. Context can include the technical details, an explanation of where the line appears in the actual product or screenshot showing the location of the string in a user interface. If the source string does not have any context, and it isn’t clear how to translate it, click Request and project manager will be notified that additional explanations are required.

Request context

Some strings might have underlined words or expressions. This means the word or expression belongs to the project terminology and should be translated according to the term description. You can check additional explanations added to the specific term for the accurate translation. This can be done by hovering over the underlined text or by going to the Terms section on the right sidebar.

Some terms may have translations to them. Previously translated terms increase project texts consistency. To reuse the term translation, you have to click the underlined term, and its translation will appear in the translation field.

Terminology

Enter the translation into the field under the original text on the central section and click Save. You will be automatically redirected to the next string.

Save translation

Some strings may have plural forms. Depending on the language, the number of plural forms may vary. For example, Chinese has one plural form, English has two plural forms, and other languages might have even up to six plural forms. Crowdin works with plural forms according to CLDR Language Plural Rules.

Read more about CLDR Language Plural Rules.

When a string has multiple plural forms, all variants of the string are shown in the section where you type in translations. Enter translations in the corresponding tabs that depict plural forms of the target language.

Plural tabs

You might also get automatic Quality Assurance (QA) check pop-up messages to avoid some translation inaccuracy. For example, you can see notifications about inconsistency in punctuation, space mismatch, missing variables, and more.

QA pop-up

Clicking icon in the top right allows you to:

  • Copy String URL to access specific string using its unique link or share it with colleagues.
  • access Translation History to see all the modifications done to the string. In the translation window, you will also see the Maximum length of translation limit if it’s exceeded.

Section 2

Additional buttons available in the translations section:
Copy Source - Copy Source. Use to keep the initial string structure while translating messages with replacement tokens or elements of ICU message syntax.
Clear Translation - Clear. Use if you need to erase the whole suggestion quickly.
Text selection mode - Text selection mode. Use if you want to copy part of translations from Translation Memory (TM) or Machine Translations (MT).

Section 3 - Middle-bottom area

This section contains the resources that might be useful:

  • Oversættelser fra øvrige projektmedlemmer
  • Forslag fra Oversættelseshukommelsen (TM)
  • Machine Translation (MT) suggestions
  • Oversættelser til andre sprog

Click on one of the suggestions, and it will automatically appear in the translation field. Refer to it as a basis for own suggestions.

To quickly copy the TM or MT suggestion to the translation field and save it, click Use and Save icon on the desired suggestion.

Other Languages section allows you to check the string translations into other target languages. This can be a useful tip for multilingual people and while translating dialects of a language.

Other languages

If you see that there is already a correct suggestion, vote for it. To vote for several translations it would be more convenient switching to Side-by-Side Mode.

Vote

If you are a proofreader and plan to review and approve more than one translation — switch to Side-by-Side Mode.

Section 4 - Right sidebar

Kommentarer

Using the Comments tab, you can discuss the meaning of the source string or other related questions. It is recommended to use a source language of the project so other translators could understand it. Use “@” and username to direct your message to the specific person.

Kommentarer

If there is a mistake in the source string, the translation is wrong, or additional context is required, you can report the issue to the project manager by selecting the Issue checkbox.

Issue

The issue is reported to the project managers, so they can correct mistakes or add context, and resolve the issue. You can also Edit, Resolve, or Delete your issue by hovering over it.

Issue options

Search TM

By going to the Search TM tab you can check for all the available translations from Translation Memory that is the vault of translations uploaded to the system by Project Managers.

Search TM

Terms

Terms tab can be used to see the existing glossary available for the string (if any). You can also search for the terms in project glossary.  If the specific term is not available in the project’s glossary, the system will show you Wikipedia explanations.

Terms

Side-by-Side Mode

In Side-by-Side mode, translators can also translate, although, this mode is mostly intended for comfortable voting for multiple best translations in a row, while managers and proofreaders can approve the best translations.

To switch to the Side-by-Side mode, open the Menu in the top left corner then choose View > Side-by-Side.

For translators

To vote click on the plus sign if you like the translation, minus - if the translation doesn’t seem correct. Oversættelserne, som får flest plusstemmer, vil derefter blive vist oven over alle tilgængelige strengoversættelser.

Side-by-Side Voting

For proofreaders

Review the translations to make sure they are ready for export and click Approve icon next to the suggestion to approve each translation separately.

To approve all or a couple of the strings at once, check the boxes on the left and then click Approve.

Side-by-Side Proofreading

Note: Make sure to enable QA checks to help you find strings that require review. Issues found will be highlighted in red under the translated strings that require revision.

QA issues

Suggesting Translations

To suggest another translation сlick on the text you want to change and when done click Save. Your translation will be added to the list of other suggestions.

Save suggestion

Translating RTL Languages

When translating between LTR and RTL languages, some elements in the translation field in the Editor might not be displayed the same way as they will be once exported.

To be sure that RTL translations will be displayed correctly in the exported file, we recommend making translations the following way:

  1. Click under the source text (or Alt+C key combination).
  2. Translate the source texts into the target language.
  3. Leave variables, tags, etc. unchanged in the translation, even if they look wrong. They will be in the right positions in the exported file.

Save suggestion

Editor Settings

To open the Editor settings, click gear icon in the right upper corner.

Settings

Editor Settings include the following setup:

  • Translation Memory Suggestions – you can specify the minimum similarity match (in percentages) for translation memory suggestions shown under the translation field.
  • Compact strings view – if enabled only the beginnings of the long strings will be shown in the string list.
  • QA checks – if enabled the pop-up messages with warnings will appear each time you try to save a translation with some inaccuracy (punctuation/tags/spaces mismatch, missing variables etc.)
    Validators

  • Auto-complete – if enabled the pop-up with translation prediction and automatic translation completion will appear while you type the translation.
  • HTML Tags Displaying – you can choose Show or Hide option that applies to all HTML tags. In case you choose Auto tags will be hidden in HTML, Haml, XML, Web XML, Markdown, Docx files but shown in other file formats. When tags are hidden you can expect that, for example:
    <a href="https://sample.com">Sample</a>
    

    will be replaced with

    <0>Sample</0>
    
  • Color Theme – choose between default Light and Dark theme.
    Settings

Helpful tips

Tastaturgenveje

Use keyboard shortcuts to take actions in the editor quickly. Check the list of keyboard shortcuts by clicking the keyboard icon in the right upper corner. Most of the hotkeys can be customized to your personal preferences. Klik på den ønskede tastekombination og ændr den vha. dit tastatur.

Tastaturgenveje

Easy access to most-used menu items in one click:

  • Language – click on the current language (French in the below screenshot)
  • Files – click on the current file name (impact.xml in the below screenshot)
  • Editor Mode – click on the current step (Translate in the below screenshot)
    Quick access

Useful options for source words

To check Translation Memory suggestions for a particular word or phrase, select it in the source string and choose Search TM from the menu. You can also search for a word or phrase explanation in project terminology and Wikipedia.

Note: Create Term option in this section is available for managers only.

Searh term

Switching to Another File

To translate strings from the other files, follow these steps:

  1. Open the Menu or click on the current file name in the top left corner.
  2. Choose File > Open.
    Open file
  3. Select the necessary file and click Open. Alternatively just double-click on the necessary file.
    Choose file

To see all strings of the project, use the Menu in the top left corner, go to File > All Strings. Alternatively click on the current file name in the top left corner > All Strings.

Replace in Suggested Translations

You can easily find and replace suggested translations using the Replace in Translations feature.

To change your previously added translations into the new ones, follow these steps:

  1. On the Project page select the necessary language.
  2. Click All Strings > Translation or choose a file for translation.
  3. Open the Menu in the top left corner.
  4. Go to File > Replace in Translations.
    Replace translations
  5. Insert the word, phrase, or sentence you want to substitute and the text to replace it with.
    Insert text
  6. Click Preview to find the strings that will be replaced.
    Preview
  7. Select the translations you’d like to replace and click Replace Selected to finish.

Advanced Filter

You can create a custom filter of strings by clicking the Filter strings icon and choosing Advanced Filter option.
You can choose multiple filter parameters (e.g., strings added, strings updated, translations updated, Labels and more) based on your specific needs to sort the strings. This might help to find the necessary information much faster.

In the below screenshot, you may see the strings are filtered by Translations updated interval, the Labels that the filtered strings should be marked with, the Comments, Visibility, and Approved by parameters as well as sorted by Alphabet in Descending order. Advanced Filter

Hide Context in Side-by-Side Mode

Context is shown by default. Use Info icon to hide context and other information like translation or approval date, suggestion authors. Without any context, strings take less space on the screen.

Hide Context

Tasks in the Editor

Once a translator or proofreader has a task assigned, all the task details are accessible from the editor:

  1. Name of the task is displayed on the top of the toolbar.
  2. Filters and searches apply to a particular task only.
  3. Task details can be accessed by clicking the menu on the top left corner.

Task menu consists of the following components and features:

  • name, due date, language, and type of the task
  • options to download and upload translations for the particular task
  • possibility to quit the particular task (“Quit Editor” button) editor and return to the task list Task Menu

Var denne artikel nyttig?