Çevrimiçi Düzenleyici

Çeviriler çoğunlukla Düzenleyicide Rahat veya Yan Yana kipinde görüntülenebilir. Genellikle Rahat kipi etkinleştirilmiştir.

Sol üst köşedeki Menü simgesini kullanarak çeviriler için dosyalar arasında geçiş yapabilir, çeviri dilini değiştirebilir, yöneticiye ulaşabilir, görünümü değiştirebilir, yardım alabilir veya düzenleyiciden çıkabilirsiniz.

Rahat Kipi

Rahat kipi çoğunlukla çeviriler için kullanılır ve dört ana bölümden oluşur:

  1. Sol kenar çubuğu
  2. Orta-üst alan
  3. Orta-alt alan
  4. Sağ kenar çubuğu

Düzenleyici Bölümleri

Bölüm 1 - Sol kenar çubuğu

Bu bölümde, dizgi listesini göreceksiniz ve etkin olan vurgulanacaktır. Dizgiler ya tek tek kelimeler, ifadeler ya da cümleler olan metin öğeleridir. Bazı dizgiler değiştirme belirteçleri ({0}, {1} veya %1 gibi birşey) ya da ICU ileti sözdizimi öğeleri olabilir. Bu tür öğelerin kendileri çevrilmemelidir, ancak web sitesi kodu tarafından dizgilere değişken olarak bazı bilgiler eklemek için kullanılır. Bu tür dizgilerle çalışmak için kaynak dizgiyi kopyalamalı ve sadece gerçek kelimeleri çevirmelisiniz.

Dizgiler aşağıdaki durumlara sahip olabilir:

  • Çevrilmemiş - çevrilmemiş
  • Çevrilmemiş çoğul biçimler - kısmen çevrilmiş (çoğul biçimlerin bazılarının çevrilmediği durumda)
  • Çevirilmiş - çevrilmiş
  • Onaylanmamış çoğul biçimler - kısmen onaylanmış (bazı çoğul biçimlerin onaylanmadığı durumda)
  • Onaylanmış - onaylanmış
  • Gizli - gizli (sadece proje yöneticileri ve düzeltmenler için görünür)

Dizgilerin yanı sıra aşağıdaki simgeler de olabilir:

  • Yorumları Olan - dizgide katkıda bulunanların yorumları var
  • Sorunu Olan - dizgide çözülmemiş bir sorun var

HTML, XML, TXT, DOCX, HAML, Web XML ve Markdown dosya biçimlerinin içeriği çevrilirken, dosya önizlemesi olarak bir dizgi listesi görüntülenir. Dizgilerin durumları aşağıdaki renklerle işaretlenir:

  • Kırmızı - çevrilmemiş
  • Açık yeşil - çevrilmiş
  • Yeşil - onaylanmış
  • Gri - çeviri için değil

Etkin bir dizgi sarı renkle vurgulanır.

HTML görünümü

Yukarıdaki görünümü yönetmek için aşağıdaki seçenekler mevcuttur:

  • Temel Liste Görünümü - temel liste görünümünü yükle. Standart kipe geçmek ve dizgilerin listesini görmek için kullanın.
  • Dizgileri Vurgula - çevrilmemiş, çevrilmiş ve onaylanmış dizgileri vurgula. Dizgilerin renk vurgularını açmak/kapatmak için kullanın.
  • Çeviri Önizleme - çeviri önizlemesini göster. Çeviri önizleme kipini açmak/kapatmak için kullanın.

HTML görünüm seçenekleri

You can search for strings by source text, translations, context, or everything at once. Depending on the content you opened in the Editor, the system will look for matches within the particular opened file or all strings in the project.

To search for strings in the file or the whole project, type your search phrase in the Search in file (Search strings) field. You can also use a keyboard shortcut to switch to the search field (by default, Ctrl+F).

To fine-tune the search results, you can use the following options:

  • Match case – With this option, you will find only the strings written in the same case: for example, if you search for Work and select Match case, the system will find Work, Works, Working but not work.
  • Match whole phrase – With this option, you will find the strings that contain the search phrase only in the original order: for example, if you search for Machine Translation and select Match whole phrase, the system will find Machine Translation, Machine translation, machine translation but not Translation Machine. When Match whole phrase isn’t active, the system splits the search phrase into separate words and searches for matches in the strings in any order.
  • Exact match – With this option, you will find only the strings that exactly match the search phrase: for example, if you search for Work and select Exact match, the system will find Work, work, but not Works or Working.

You can combine Match case with Exact match and Match case with Match whole phrase. Match whole phrase and Exact match are mutually exclusive options.

The search phrase is limited to 128 characters. If you paste a search phrase greater than 128 characters, it will be automatically trimmed down to the maximum allowed limit.

String Search

Dizgileri Süzme

To filter the strings displayed in the left sidebar, click and select the preferred filter option.

Available filter options:

  • Show All – Show all strings from the opened file/folder in the original order.
  • All, Untranslated First – Show all strings from the opened file/folder. Untranslated strings are displayed at the top of the list, then translated strings, and the approved ones are displayed at the bottom of the list.
  • Untranslated – Show only strings without any translations.
  • Need to Be Voted – Show already translated strings.
  • Not Approved – Show strings that are already translated but not yet approved by a proofreader.
  • Approved – Show only strings with approved translations.
  • QA issues – Show strings with no QA issues or with unresolved QA issues in the current language.
  • Machine Translation – Show strings that are translated by TM or MT suggestions without changes. Often such strings need additional review.
  • With Comments – Show strings that have comments.
  • With Unresolved Issues – Show strings with unresolved issues in the current language or all languages.
  • Hidden – Show strings that are hidden from translators. Strings can be hidden by project managers or hidden automatically by Crowdin Enterprise when they are marked as duplicates.
  • Advanced Filter – Filter that allows configuring own filtering and sorting parameters.

Dizgiler süzgeci

Verbal Expressions

The Verbal Expression section implements a regular expression search. You can set specific search parameters for strings in your project. For example, you can search for all strings that begin with capital letters and have no dots at the end or contain a date.

Note: When you enable verbal expressions, you cannot use regular string search.

For example, if you’d like to extract all strings that start with a capital letter and have a dot at the end, your expression might look like this: start, then "A,Z", anything, range "a,z,A,Z,0,9", limit "1,", then ".", end

Let’s break down the expression above.

start – indicates the beginning of the expression.
then "A,Z" – means that your expression starts with characters ranging A-Z.
range "a,z,A,Z,0,9" – means that your custom placeholder might include characters ranging a-z and/or A-Z and/or 0-9.
limit "1," – means that the length of the expression is from 1 character.
then "." – means that your expression ends with a dot.
end – indicates the end of the expression.

To configure a verbal expression, use the following expression syntax.

Clicking icon  will help to view the strings with corresponding workflow statuses. In every project, strings move from one workflow step to the next one. There are two statuses ToDo and Done.

Status filter

Bölüm 2 - Orta-üst alan

Üstteki kaynak dizgi ve aşağıdaki çeviri bölümü ile ana çalışma alanı. Bir çeviri eklemek için sol bölümden dizgiyi seçmeniz gerekir ve bu orta üst Kaynak Dizgi alanında görünecektir.

Çeviri için metin

Bu alan ayrıca bir dizginin bağlamını da gösterir. Bağlam, teknik ayrıntıları, satırın gerçek üründe nerede göründüğünün bir açıklamasını veya dizginin kullanıcı arayüzündeki konumunu gösteren ekran görüntüsünü içerebilir. Eğer kaynak dizginin herhangi bir bağlamı yoksa ve nasıl çevrileceği açık değilse, İstek seçeneğine tıklayın ve böylece proje yöneticisi ek açıklamaların gerekli olduğu konusunda bilgilendirilecektir.

Bağlam isteyin

Bazı dizgilerde altı çizili kelimeler veya ifadeler olabilir. Bu, kelime veya ifadenin proje terminolojisine ait olduğu ve terim açıklamasına göre çevrilmesi gerektiği anlamına gelir. Doğru çeviri için belirli bir terime eklenen ek açıklamaları gözden geçirebilirsiniz. Bu, altı çizili metnin üzerine fare ile gelerek veya sağ kenar çubuğundaki Terimler bölümüne giderek yapılabilir.

Bunlar için bazı terimlerin çevirileri olabilir. Önceden çevrilmiş terimler proje metinlerinin tutarlılığını artırır. Terim çevirisini yeniden kullanmak için altı çizili terime tıklamak zorundasınız ve çevirisi, çeviri alanında görünecektir.

Terminoloji

Çeviriyi orta bölümde orijinal metnin altındaki alana girin ve Kaydet’e tıklayın. Otomatik olarak bir sonraki dizgiye yönlendirileceksiniz.

Çeviriyi kaydedin

Plural Forms

Bazı dizgiler çoğul biçimlere sahip olabilir. Dile bağlı olarak, çoğul biçimlerin sayısı farklılık gösterebilir. Örneğin, Çince bir çoğul biçime sahiptir, İngilizce iki çoğul biçime sahiptir ve diğer diller altıya kadar çoğul biçime sahip olabilir. Crowdin, CLDR Dil Çoğul Kurallarına göre çoğul biçimlerle çalışır.

CLDR Dil Çoğul Kuralları hakkında daha fazla bilgi okuyun.

Bir dizginin birden çok çoğul biçimi olduğunda, dizginin tüm çeşitleri çevirileri yazdığınız bölümde gösterilir. Hedef dilin çoğul biçimlerini gösteren ilgili sekmelere çevirileri girin.

Çoğul sekmeleri

Bazı çeviri yanlışlıklarından kaçınmak için otomatik Kalite Güvencesi (KG) denetimi açılır iletilerini de alabilirsiniz. Örneğin, noktalama işaretlerindeki tutarsızlık, boşluk uyuşmazlığı, eksik değişkenler ve daha fazlası ile ilgili bildirimleri görebilirsiniz.

KG açılır ileti

Sağ üstteki simgesine tıklamak şunları yapmanızı sağlar:

  • benzersiz bağlantısını kullanarak belirli dizgiye erişmek veya iş arkadaşlarınızla paylaşmak için Dizgi URL’sini Kopyala’yın.
  • dizgide yapılan tüm değişiklikleri görmek için Çeviri Geçmişi’ne erişin. Çeviri penceresinde, aşıldıysa En fazla çeviri uzunluğu sınırını da göreceksiniz.

Bölüm 2

Çeviriler bölümünde bulunan ek düğmeler:
Copy Source - Kaynağı Kopyala. İletileri değiştirme belirteçleri veya ICU ileti sözdizimi öğeleriyle çevirirken ilk dizgi yapısını korumak için kullanın.
Çeviriyi Temizleyin - Temizle. Bütün öneriyi hızlı bir şekilde silmeniz gerekiyorsa kullanın.
Metin seçim kipi - Metin seçim kipi. Çevirilerin bir kısmını Çeviri Belleği (ÇB) veya Makine Çevirileri’nden (MÇ) kopyalamak istiyorsanız kullanın.

Bölüm 3 - Orta-alt alan

Bu bölüm faydalı olabilecek kaynakları içerir:

  • Diğer proje katılımcılarının çevirileri
  • Çeviri Belleği (ÇB) önerileri
  • Makine Çevirisi (MÇ) önerileri
  • Diğer dillere çeviriler

Önerilerden birini tıklayın ve otomatik olarak çeviri alanında görünecektir. Kendi önerileriniz için temel alın.

ÇM veya MÇ önerisini hızlı bir şekilde çeviri alanına kopyalamak ve kaydetmek için istenen öneri üzerindeki Kullan ve Kaydet simgesine tıklayın.

Diğer Diller bölümü, dizgi çevirilerini diğer hedef dillerde gözden geçirmenizi sağlar. Bu, çok dilli insanlar için ve bir dilin lehçelerini çevirirken yararlı bir ipucu olabilir.

Diğer diller

Eğer zaten doğru bir öneri olduğunu görürseniz, oy verin. Birkaç çeviriye oy vermek için Yan Yana Kipine geçmek daha uygun olacaktır.

Oy

Eğer bir düzeltmenseniz ve birden fazla çeviriyi gözden geçirmeyi ve onaylamayı planlıyorsanız — Yan Yana Kipine geçin.

Bölüm 4 - Sağ kenar çubuğu

Açıklamalar

Yorumlar sekmesini kullanarak kaynak dizginin anlamını veya ilgili diğer soruları tartışabilirsiniz. Diğer çevirmenlerin anlayabilmesi için projenin kaynak dilini kullanmanız önerilir. İletinizi belirli bir kişiye yönlendirmek için “@” ve kullanıcı adını kullanın.

Açıklamalar

Reporting Issues

Additionally, in the Comments tab, you can report the issues regarding the source strings or translations to the project managers by selecting the Issue checkbox.

Available issue types:

  • General question – General question related to the source string or its translations.
  • Current translation is wrong – The translation added to the source string is incorrect and requires correction.
  • Lack of contextual information – The meaning of the string isn’t clear and requires additional clarifications.
  • Mistake in the source string – The source string text contains typos or any other mistakes.

All strings with unresolved issues could be filtered using the With Unresolved Issues options.

Read more about Filtering Strings.

Sorun

The issues are reported to the project managers to correct mistakes or add context and resolve the issues. Ayrıca sorununuzu fare ile üzerine gelerek Düzenle’yebilir, Çöz’ebilir veya Sil’ebilirsiniz.

Sorun seçenekleri

If the project owner or managers configured the integration with Jira, all reported issues will be directed to the Jira dashboard for further processing and resolution without the need to visit Crowdin Editor.

Read more about Jira Integration.

ÇB Ara

By going to the Search TM tab, you can check for all the available translations from Translation Memory that is the vault of translations uploaded to the system by project managers.

The Search TM tab provides the following options:

  • Source – Search for matches in a source language.
  • Target – Search for matches in target languages.
  • Guess translation – Highlight probable translation of a search phrase.
  • Numeric equivalence – Match digits from a search phrase with any other digits.

Additionally, to maximize your search results, you can use the following wildcards with your search phrase:

Type an asterisk (*) to find words where the end or beginning may be different.
Example: any* finds any, anyway, anything
Example: *way finds way, anyway, highway

Type a plus sign (+) to find words where the end or beginning must be different.
Example: any+ finds anyway, anything, anywhere, except any
Example: +way finds anyway, highway, someway, except way

Type a minus sign (-) to exclude words from your search.
Example: Save -as

Use quotation marks to find the exact combination of words.
Example: “Save as”

ÇB Ara

Terimler

Terimler sekmesi, dizgi için uygun varolan sözlüğü (varsa) görmek için kullanılabilir. You can also search for the terms in project glossary.  If the specific term is not available in the project’s glossary, the system will show you Wikipedia explanations.

Terimler

Yan Yana Kipi

Bu kip çoğunlukla art arda birden çok en iyi çeviriyi rahat oylamaya yönelik olmasına rağmen, Yan Yana kipinde çevirmenler de çeviri yapabilir, yöneticiler ve düzeltmenler en iyi çevirileri onaylayabilir.

Yan Yana kipine geçmek için sol üst köşedeki Menü’yü açın, ardından Görünüm > Yan Yana’yı seçin.

Çevirmenler için

Çeviriyi beğendiyseniz oy vermek için artı işaretine, çeviri doğru görünmüyorsa eksi işaretine tıklayın. Daha sonra en çok olumlu oyu alan çeviriler dizgi için mevcut olan tüm çevirilerin üstünde görünecek.

Yan Yana Oy Verme

Düzeltmenler için

Dışa aktarmaya hazır olduklarından emin olmak için çevirileri inceleyin ve her bir çeviriyi ayrı olarak onaylamak için önerinin yanındaki Onayla simgesine tıklayın.

Dizgilerin tümünü veya birkaçını aynı anda onaylamak için soldaki kutuları işaretleyin ve sonra Onayla’ya tıklayın.

Yan Yana Düzeltme Okuması

Note: Make sure to enable QA checks to help you find strings that require review. Bulunan sorunlar, düzeltim gerektiren çevrilmiş dizgilerin altında kırmızı renkle vurgulanacaktır.

KG sorunları

Çeviriler Önerme

Başka bir çeviri önermek için değiştirmek istediğiniz metne tıklayın ve tamamlandığında Kaydet’e tıklayın. Çeviriniz diğer öneriler listesine eklenecektir.

Öneriyi kaydedin

RTL Dilleri Çevirme

LTR ve RTL dilleri arasında çeviri yaparken, Düzenleyicide çeviri alanındaki bazı öğeler bir kez dışa aktarılacak şekilde görüntülenmeyebilir.

Dışa aktarılan dosyada RTL çevirilerinin doğru olarak görüntüleneceğinden emin olmak için çevirileri aşağıdaki şekilde yapmanızı öneririz:

  1. Kaynak metnin altındaki simgesine (veya Alt+C tuş birleşimine) tıklayın.
  2. Kaynak metinleri hedef dile çevirin.
  3. Leave variables, tags, etc. unchanged in the translation, even if they look wrong. Dışa aktarılan dosyada doğru konumlarda olacaklardır.

Öneriyi kaydedin

Düzenleyici Ayarları

To open the Editor settings, click in the right upper corner.

Ayarlar

Düzenleyici Ayarları aşağıdaki ayarları içerir:

  • Çeviri Belleği Önerileri – çeviri alanında gösterilen çeviri belleği önerileri için en az benzerlik eşleşmesini (yüzde olarak) belirleyebilirsiniz.
  • Sıkışık dizgiler görünümü – eğer etkinleştirilirse, dizgi listesinde uzun dizgilerin sadece başlangıçları gösterilecektir.
  • KG denetimleri – eğer etkinleştirilirse, bazı yanlışı olan çeviriyi her kaydetmeye çalıştığınızda uyarı içeren açılır iletiler görünecek (noktalama işaretleri/etiketler/boşluk uyuşmazlığı, eksik değişkenler vb.)
    Doğrulayıcılar

  • Otomatik tamamlama – eğer etkinleştirilirse, çeviriyi yazarken çeviri tahmini ve otomatik çeviri tamamlama içeren açılır pencere görünecek.
  • Auto-approve – if enabled the translations added by proofreaders or members with higher permissions are automatically approved.
  • HTML etiketleri görüntüleme – tüm HTML etiketlerine uygulanan Göster veya Gizle seçeneğini seçebilirsiniz. Otomatik’i seçmeniz durumunda, etiketler HTML, Haml, XML, Web XML, Markdown, Docx dosyalarında gizlenecek ancak diğer dosya biçimlerinde gösterilecektir. Etiketler gizlendiğinde şunu bekleyebilirsiniz, örneğin:
    <a href="https://sample.com">Örnek</a>
    

    şununla değiştirilecektir:

    <0>Örnek</0>
    
  • Color Theme – set the Light or Dark theme, or select Auto to allow the Editor to set the theme based on your device system settings.
    Ayarlar

Yararlı ipuçları

Klavye Kısayolları

Düzenleyicide hızlı bir şekilde işlem yapmak için klavye kısayollarını kullanın. Sağ üst köşedeki klavye simgesine tıklayarak klavye kısayolları listesini gözden geçirin. Kısayol tuşlarının çoğu kişisel tercihlerinize göre özelleştirilebilir. Gerekli tuş birleşimine tıklayın ve klavyenizin yardımıyla bunu değiştirin.

Klavye Kısayolları

Tek bir tıklamayla en çok kullanılan menü öğelerine kolay erişim:

  • Dil – şu anki dile tıklayın (aşağıdaki ekran görüntüsündeki Fransızca)
  • Dosyalar – şu anki dosya adına tıklayın (aşağıdaki ekran görüntüsündeki impact.xml)
  • Düzenleyici Kipi – şu anki adıma tıklayın (aşağıdaki ekran görüntüsündeki Çevir)
    Hızlı erişim

Kaynak kelimeler için yararlı seçenekler

Belirli bir kelime veya ifade için Çeviri Belleği önerilerini gözden geçirmek için bunu kaynak dizgide seçin ve menüden ÇB Ara’yı seçin. Proje terminolojisinde ve Vikipedi’de bir kelime veya ifade açıklaması da arayabilirsiniz.

Not: Bu bölümdeki Terim Oluştur seçeneği sadece yöneticiler tarafından kullanılabilir.

Terim arayın

Başka Bir Dosyaya Geçme

Dizgileri diğer dosyalardan çevirmek için şu adımları izleyin:

  1. Menü’yü açın veya sol üst köşedeki şu anki dosya adına tıklayın.
  2. Dosya > Aç’ı seçin.
    Dosya açın
  3. Gerekli dosyayı seçin ve ’a tıklayın. Alternatif olarak, gerekli dosyaya yalnızca çift tıklayın.
    Dosya seçin

Projenin tüm dizgilerini görmek için sol üst köşedeki Menü’yü kullanın, Dosya > Tüm Dizgiler’e tıklayın. Alternatif olarak, sol üst köşedeki şu anki dosya adına > Tüm Dizgiler’e tıklayın.

Önerilen Çevirilerde Değiştirin

Çevirilerde Değiştir özelliğini kullanarak önerilen çevirileri kolayca bulabilir ve değiştirebilirsiniz.

Önceden eklediğiniz çevirileri yenileriyle değiştirmek için şu adımları izleyin:

  1. Projesi sayfasında gerekli dili seçin.
  2. Tüm Dizgiler > Çeviriye tıklayın veya çeviri için bir dosya seçin.
  3. Sol üst köşedeki Menü’yü açın.
  4. Dosya > Çevirilerde Değiştir’e tıklayın.
    Çevirileri değiştirin
  5. Değiştirmek istediğiniz kelimeyi, ifadeyi veya cümleyi ve bununla değiştirilecek metni girin.
    Metin ekleyin
  6. Değiştirilecek dizgileri bulmak için Önizle’ye tıklayın.
    Önizleyin
  7. Değiştirmek istediğiniz çevirileri seçin ve tamamlamak için Seçileni Değiştir’e tıklayın.

Gelişmiş Süzgeç

Dizgileri süz simgesine tıklayarak ve Gelişmiş Süzgeç seçeneğini seçerek özel bir dizgi süzgeci oluşturabilirsiniz.
You can choose multiple filter parameters (e.g., strings added, strings updated, translations updated, Labels and more) based on your specific needs to sort the strings. Bu, gerekli bilgileri daha hızlı bulmanıza yardımcı olabilir.

Aşağıdaki ekran görüntüsünde, dizgilerin Azalan sırada Alfabe’ye göre sıralanmasının yanı sıra, Çeviriler güncellendi aralığı, süzülen dizgilerin işaretlenmesi gereken Etiketler, Yorumlar, Görünürlük ve Onaylayan parametrelerine göre süzüldüğünü görebilirsiniz.

Gelişmiş Süzgeç

Bağlamı Yan Yana Kipinde Gizleyin

Bağlam varsayılan olarak gösterilir. Bağlamı ve çeviri ya da onay tarihi, öneri yazarları gibi diğer bilgileri gizlemek için Bilgi simgesini kullanın. Herhangi bir bağlam olmadan, dizgiler ekranda daha az yer kaplar.

Bağlamı Gizleyin

Düzenleyicide Görevler

Bir çevirmene veya düzeltmene bir görev atandıktan sonra, tüm görev ayrıntılarına düzenleyiciden erişilebilir:

  1. Görevin adı araç çubuğunun üstünde görüntülenir.
  2. Süzgeçler ve aramalar sadece belirli bir göreve uygulanır.
  3. Görev ayrıntılarına sol üst köşedeki menüye tıklayarak erişilebilir.

Görev menüsü aşağıdaki bileşenlerden ve özelliklerden oluşur:

  • görevin adı, bitiş tarihi, dili ve türü
  • belirli görev için çevirileri indirme ve yükleme seçenekleri
  • belirli görev (“Düzenleyiciden Çık” düğmesi) düzenleyicisinden çıkma ve görev listesine dönme imkanı Görev Menüsü

Bu makale yararlı oldu mu?