Online szerkesztő

A fordítások főként a Szerkesztőben készülnek, amelyek Kényelmes vagy Egymás melletti módban tekinthetők meg. Általában a Kényelmes mód van engedélyezve.

A bal felső sarokban lévő Menü segítségével válthat a fordítandó fájlok között, módosíthatja a fordítás nyelvét, léphet kapcsolatba a menedzserrel, nézetet válthat, segítséget kérhet, vagy kiléphet a szerkesztőből.

Kényelmes mód

Kényelmes mód elsősorban a fordításokhoz használható és négy fő részből áll:

  1. Bal oldalsáv
  2. Középső-felső terület
  3. Középső-alsó terület
  4. Jobb oldalsáv

Szerkesztő szakaszai

Szakasz 1 - Bal oldalsáv

Ebben a szakaszban jelenik meg a karakterláncok listája, és az aktív kiemelésre kerül. A karakterláncok olyan szöveges elemek, amelyek külön szavak, kifejezések vagy mondatok lehetnek. Néhány karakterláncban helyettesítő tokenek (például: {0}, {1} vagy %1) vagy az ICU üzenet szintaxis elemei is előfordulhatnak. Az ilyen elemeket nem kell lefordítani, mivel ezeket a webhely kódsora használja arra, hogy bizonyos információkat dinamikusan beillesszen a karakterláncokba. Az ilyen karakterláncok esetén másolja a forrás-karakterláncot, és csak a valódi szavakat fordítsa le.

A karakterláncok állapota a következő lehet:

  • Lefordítatlan - lefordítatlan
  • Lefordítatlan többes számú alakok - részben lefordított (abban az esetben, ha néhány többes számú alak nincs lefordítva)
  • Lefordított - lefordított
  • Jóvá nem hagyott többes számú alakok - részben jóváhagyott (abban az esetben, ha néhány többes számú alak nincs jóváhagyva)
  • Jóváhagyott - jóváhagyott
  • Rejtett - rejtett (csak a projektmenedzsereknek és lektoroknak látható)

A karakterláncoknál a következő ikonok is megjelenhetnek:

  • Hozzászólásokkal - a karakterlánchoz hozzászóltak a közreműködők
  • Problémákkal - a karakterlánchoz megoldatlan probléma társul

A HTML, XML, TXT, DOCX, HAML, Web XML és Markdown formátum tartalmának fordítása közben a karakterláncok listája fájl előnézetként jelenik meg. A karakterláncok állapota a következő színekkel van jelölve:

  • Piros - lefordítatlan
  • Világoszöld - lefordítva
  • Zöld - jóváhagyva
  • Szürke - nem fordítandó

Az aktív karakterlánc a sárga színnel kerül kiemelésre.

HTML nézet

A következő lehetőségek állnak rendelkezésre a fenti nézet kezeléséhez:

  • Alap listanézet - alap lista nézet betöltése. A gomb segítségével válthat a normál módra, és térhet át a listanézetre.
  • Karakterláncok kiemelése - a le nem fordított, lefordított és jóváhagyott karakterláncok kiemelése. A karakterláncok színes kiemelésének be- és kikapcsolására szolgál.
  • Fordítás előnézet - fordítási előnézet megjelenítése. A fordítások előnézetének be- és kikapcsolására szolgál.

HTML nézet opciók

A Karakterláncok szűrése ikonra kattintva a kívánt módon szűrheti a karakterláncokat. Például a csak le nem fordított karakterláncokat is kiszűrheti, amint az az alábbi képernyőképen is látható.

Karakterlánc szűrő

Szakasz 2 - Középső-felső terület

A fő munkaterület, a forrás-karakterlánccal a tetején és alatta a fordítási területtel. A fordítás hozzáadásához ki kell választania a karakterláncot a bal oldali szakaszból, ezután az megjelenik a központi Forrás-karakterlánc szövegmezőben.

Text for translation

Ezen a területen jelenik meg a karakterlánc szövegösszefüggése is. A szövegösszefüggés lehet technikai részlet, annak magyarázata, hogy a sor hol jelenik meg az adott termékben, vagy képernyőkép, amely megmutatja a karakterlánc helyét a felhasználói felületen. Ha a forrás-karakterlánchoz nincs szövegösszefüggés, és nem világos, hogyan kell lefordítani, kattintson Kérelem lehetőségre, így a projektmenedzsert értesítjük, hogy további magyarázatokra van szükség.

Összefüggés kérése

Néhány karakterláncban aláhúzott szavak vagy kifejezések jelenhetnek meg. Ez azt jelenti, hogy a szó vagy kifejezés a projekt terminológiájához tartozik, és azt a kifejezéshez tartozó leírás szerint kell lefordítani. A pontos fordítás érdekében megtekintheti az adott kifejezéshez tartozó magyarázó leírást. Ehhez vigye az aláhúzott szöveg fölé az egeret, vagy menjen a jobb oldali sáv Kifejezések szakaszába.

Néhány kifejezés fordítással is rendelkezik. A korábban lefordított kifejezések növelik a projekt szövegének következetességét. A kifejezés fordításának újbóli felhasználásához kattintson az aláhúzott kifejezésre, és annak fordítása megjelenik a fordítási mezőben.

Terminológia

Írja be a fordítást az eredeti szöveg alatti mezőbe, majd kattintson a Mentés gombra. Automatikusan átirányításra kerül a következő karakterlánchoz.

Fordítás mentése

Néhány karakterláncnak többes számú alakja is lehet. A nyelv függvényében a többes számú alakok száma változhat. Például a kínai nyelvben egy többes számú alak van, az angolban kettő, és van olyan nyelv amelynek akár hat többes számú alakja is lehet. Crowdin a többes számú alakok esetén a CLDR Nyelvek többes számainak szabályai szerint működik.

További információkhoz nézze meg a CLDR Nyelvek többes számainak szabályait.

Ha egy karakterláncnak több többes számú alakja van, akkor a karakterlánc minden variációja megjelenik abban a szakaszban, ahol a fordítást írja. Adja meg a fordításokat a megfelelő lapon, amelyek a célnyelv többes számú formáját ábrázolják.

Többes lapok

Előfordulhat, hogy automatikus minőség-ellenőrzési (ME) felugró üzeneteket is kap a fordítási pontatlanságok elkerülése érdekében. Például értesítéseket láthat az írásjelek inkonzisztenciájáról, a szóköz eltérésről, a hiányzó változókról és egyebekről.

ME figyelmeztetés

A jobb felső ikonra kattintva a következő lehetőségeket éri el:

  • Karakterlánc URL másolása az adott karakterlánc egyedi hivatkozással való eléréséhez, vagy a kollégáival való megosztáshoz.
  • a Fordítási előzmények elérése a karakterláncon elvégzett összes módosítás megtekintéséhez. A fordítási ablakban a Fordítás maximális hossza korlát is megjelenik, ha túllépésre kerül.

Szakasz 2

A fordítási mezőben elérhető további gombok:
Copy Source - Forrás másolása. Ezzel megtarthatja a kezdeti helyettesítő kódok vagy ICU üzenet szintaxis elemek karakterlánc-struktúráját a szövegek fordításakor.
Fordítás törlése - Törlés. Ennek segítségével törölheti gyorsan az egész fordítási javaslatot.
Szövegkijelölési mód - Szövegkijelölési mód. Ennek segítségével másolhat szövegrészletet a Fordítási memóriából (FM) vagy a Gépi fordításokból (GF).

Szakasz 3 - Középső-alsó terület

Ez a rész tartalmazza a fordítás során hasznos forrásokat:

  • A többi projekttag fordításai
  • Fordítási Memória (FM) javaslatok
  • Gépi fordítás (GF) javaslatok
  • Más nyelvek fordításai

Kattintson az egyik javaslatra, az automatikusan megjelenik a fordítási mezőben. Tekintse meg a saját javaslatai alapjaként.

Az FM és GF javaslatok gyors használatához és mentéséhez kattintson a Használ és ment ikonra a kívánt javaslatnál.

Az Egyéb nyelvek szakaszban nézheti meg a más célnyelvekre történt fordításokat. Ez hasznos lehet a több nyelvet beszélő emberek számára, valamint egy nyelv dialektusainak fordításánál is.

Egyéb nyelvek

Ha azt látja, hogy már van egy helyes javaslat, szavazzon rá. A több fordításra való szavazáshoz sokkal kényelmesebb lenne átváltani az Egymás melletti módra.

Szavazás

Ha Ön lektor és egynél több fordítást szeretne felülvizsgálni és jóváhagyni — váltson az Egymás melletti módra.

Szakasz 4 - Jobb oldalsáv

Megjegyzések

A Hozzászólások fül segítségével vitathatják meg a forrásszöveg jelentését, vagy egyéb hozzá kapcsolódó kérdéseket. Javasoljuk, hogy a projekt forrásnyelvét használja, így más fordítók is megérthetik. Használja a “@” és felhasználónevet, hogy az üzenetet az adott személyhez intézze (említés).

Megjegyzések

Ha a forrásszövegben hiba van, a fordítás helytelen, vagy további szövegösszefüggés szükséges, a Probléma bejelölésével küldheti el a projektmenedzsernek a problémát.

Probléma

A problémáról jelentést kapnak a projektmenedzserek, így kijavíthatják a hibákat, hozzáadhatnak szövegösszefüggést, és megoldhatják a problémát. A saját bejelentett problémáját Szerkesztheti, Megoldottnak jelölheti, vagy Törölheti a problémája fölé menve.

Probléma opciók

FM keresés

Az FM keresés fülre kattintva ellenőrizheti a Fordítási memóriában rendelkezésre álló fordításokat, amely a projekt menedzserei által a rendszerbe feltöltött fordítások tárolója.

FM keresés

Kifejezések

A Kifejezések lapon megtekinthető a karakterlánchoz rendelkezésre álló jelenlegi szójegyzék (ha van). A kifejezéseket a projekt szójegyzékében is keresheti.  Ha az adott kifejezés nem érhető el a projekt szójegyzékében, akkor a rendszer megmutatja a Wikipedia magyarázatát.

Kifejezések

Egymás melletti mód

Az egymás melletti módban a fordítók szintén fordíthatnak, bár ez az üzemmód többnyire a legjobb fordítás kényelmes szavazására szolgál, míg a menedzserek és a lektorok ebben a nézetben jóváhagyhatják a legjobb fordításokat.

Az egymás melletti módra váltáshoz, nyissa meg a Menüt a bal felső sarokban, majd válassza a Nézet > Egymás melletti lehetőséget.

Fordítóknak

A szavazáshoz kattintson a plusz jelzésre ha tetszik a fordítás, vagy a minusz -ra ha a fordítás nem tűnik jónak. Azok a fordítások, amelyek a legtöbb pozitív szavazatot kapják, jelennek meg az elkészült összes fordítás tetején.

Egymás melletti mód szavazás

Lektoroknak

Ellenőrizze a fordításokat, hogy megbizonyosodjon arról, hogy azok készek-e az exportálásra, és kattintson a javaslat mellett található Jóváhagyás ikonra az egyes fordítások külön-külön történő jóváhagyásához.

Az összes vagy néhány karakterlánc egyidejű jóváhagyásához jelölje be a bal oldali jelölőnégyzeteket, majd kattintson a Jóváhagyás gombra.

Egymás melletti mód lektorálás

Megjegyzés: Ügyeljen arra, hogy engedélyezze az ME vizsgálatokat, hogy segítsen megtalálni az ellenőrzést igénylő karakterláncokat. A feltárt problémák piros színnel lesznek kiemelve a lefordított karakterláncok alatt, melyek felülvizsgálatra szorulnak.

ME problémák

Fordítások javaslata

Ha egy másik fordítást javasol, kattintson a megváltoztatni kívánt szövegre és kattintson a Mentés gombra. A fordítás hozzáadódik a többi javaslat listájához.

Javaslat mentése

Jobbról balra (RTL) nyelvek fordítása

A “balról jobbra” (LTR) és “jobbról balra” (RTL) nyelvek közötti fordítás során a Szerkesztő fordítási mezőjének egyes elemei nem feltétlenül úgy jelennek meg, ahogyan azok majd exportálásra kerülnek.

Annak érdekében, hogy az exportált fájlban a Jobbról balra (RTL) fordítások helyesen jelenjenek meg, azt javasoljuk, hogy a fordításokat a következő módon hajtsa végre:

  1. Kattintson az ikonra a forrásszöveg alatt (vagy Alt+C billentyűkombináció).
  2. Fordítsa le a forrásszöveget a célnyelvre.

  3. Hagyja a változókat, címkéket stb. változatlanul a fordításban, akkor is, ha azok rosszul néznek ki. Az exportált fájlban a megfelelő pozícióban lesznek.

Javaslat mentése

Szerkesztő beállításai

A Szerkesztő beállításainak megnyitásához, kattintson a fogaskerék ikonra a jobb felső sarokban.

Beállítások

A Szerkesztő beállításai a következő beállításokat tartalmazzák:

  • Fordítási memória javaslatok – meghatározhatja a minimális egyezési arányt (százalékban) a fordítási terület alatt megjeleníthető fordítási memória javaslatokhoz.
  • Kompakt karakterlánc nézet – ha engedélyezve van, akkor a hosszú karakterláncoknak csak a kezdete jelenik meg a karakterláncok listájában.
  • ME vizsgálatok – ha engedélyezve van, egy figyelmeztető felugró üzenet jelenik meg minden alkalommal, amikor valamilyen pontatlansággal próbál fordítást menteni (írásjel/jelölő/szóköz eltérés, hiányzó változók, stb.)
    Érvényesítők

  • Auto-kiegészítés – ha engedélyezve van, egy előugró ablakban megjelennek a a fordítási javaslatok és a fordítás automatikus befejezése a fordítás beírása közben.
  • HTML jelölők megjelenítése – a Megjelenít vagy Elrejt opciók közül választhat, mely az összes HTML jelölőre érvényes. Ha az Automatikus opciót választja, a jelölők rejtettek a HTML, Haml, XML, Web XML, Markdown és Docx fájlokban, de megjelenítésre kerülnek az egyéb fájlformátumokban. Ha a jelölők el vannak rejtve, akkor valami hasonlóra számíthat:
    <a href="https://sample.com">Sample</a>
    

    helyett a következő jelenik meg:

    <0>Sample</0>
    
  • Színtéma – válasszon az alapértelmezett Világos, valamint a Sötét téma között.
    Beállítások

Hasznos tippek

Gyorsbillentyűk

A gyorsbillentyűk használatával gyorsan végezhet el műveleteket a szerkesztőben. A jobb felső sarokban található billentyűzet ikonra kattintva ellenőrizze a billentyűparancsok listáját. A legtöbb gyorsbillentyű személyre szabható. Kattintson a szükséges billentyűkombinációra, majd módosítsa azt a billentyűzete segítségével.

Gyorsbillentyűk

Könnyű hozzáférés a leggyakrabban használt menüpontokhoz egy kattintással:

  • Nyelv – kattintson a jelenlegi nyelvre (Francia az alábbi képernyőképen)
  • Fájlok – kattintson a jelenlegi fájlnévre (impact.xml az alábbi képernyőképen)
  • Szerkesztő Mód – kattintson a jelenlegi lépésre (Fordítás az alábbi képernyőképen)
    Gyors hozzáférés

Hasznos lehetőségek a forrásszavakhoz

Egy adott szó vagy kifejezés Fordítási memóriában lévő javaslatainak ellenőrzéséhez jelölje ki azt a forrás-karakterláncban, és válassza az FM keresés lehetőséget a megjelenő menüből. A projekt terminológiájában és a Wikipédiában is rákereshet a szóra vagy a kifejezésre.

Megjegyzés: Kifejezés létrehozása lehetőség csak a menedzserek számára érhető el.

Kifejezés keresése

Váltás másik fájlra

A karakterláncok más fájlokból történő fordításához kövesse az alábbi lépéseket:

  1. Nyissa meg a Menüt vagy kattintson az aktuális fájl nevére a bal felső sarokban.
  2. Válassza a Fájl > Megnyitás lehetőséget.
    Fájl megnyitása
  3. Válassza ki a szükséges fájlt, majd kattintson a Megnyitás gombra. Alternatívaként csak kattintson duplán a kívánt fájlra.
    Fájl kiválasztása

A projekt összes karakterláncának megtekintéséhez, nyissa meg a Menüt a bal felső sarokban, majd válassza a Fájl > Összes karakterlánc lehetőséget. Alternatív lehetőségként kattintson az aktuális fájl nevére a bal felső sarokban > Összes karakterlánc.

Csere a Javasolt fordításokban

Könnyen megtalálhatja és lecserélheti a javasolt fordításokat a Csere a fordításokban szolgáltatással.

A korábban hozzáadott fordítások újakra történő módosításához kövesse az alábbi lépéseket:

  1. A Projekt oldalon válassza ki a kívánt nyelvet.
  2. Kattintson az Összes karakterlánc > Fordítás elemre, vagy válasszon egy fájlt a fordításhoz.
  3. Nyissa meg a Menüt a bal felső sarokban.
  4. Menjen a Fájl > Csere a fordításokban lehetőségbe.
    Csere a fordításokban
  5. Illessze be a helyettesítendő szót, kifejezést, vagy mondatot, és amivel kicseréli szöveget.
    Szöveg beszúrása
  6. Kattintson az Előnézet lehetőségre, hogy megtalálja a cserével érintett karakterláncokat.
    Előnézet
  7. Jelölje ki a kicserélni kívánt fordításokat, majd kattintson a Csere a kijelöltekben elemre a befejezéshez.

Irányított szűrő

Egyéni szűrést hozhat létre a Karakterláncok szűrése ikonra kattintva és az Irányított szűrő lehetőséget választva.
Több szűrési paramétert is kiválaszthat a karakterláncok rendezéséhez az adott igényei alapján. Ez segíthet a szükséges információk gyorsabb megtalálásában. Az alábbi képernyőképen azt láthatja, hogy a karakterláncok szűrése a Fordítás frissítve időintervallumra és a Jóváhagyta: paraméterre történt, illetve a rendezés ábécé szerinti Csökkenő sorrendben. Irányított szűrő

Szövegösszefüggés elrejtése az Egymás melletti módban

A szövegösszefüggés alapértelmezetten megjelenik. Az Info ikon segítségével elrejtheti a szövegösszefüggést és egyéb információkat, például a fordítás vagy a jóváhagyás dátumát, a javaslatok szerzőit. Szövegösszefüggés nélkül a karakterláncok kevesebb helyet foglalnak a képernyőn.

Összefüggés elrejtése

Feladatok a Szerkesztőben

Amint a fordító vagy a lektor egy hozzárendelt feladatot kapott, a feladat minden részletét elérheti a szerkesztőből:

  1. A feladat neve az eszköztár tetején jelenik meg.
  2. A szűrők és a keresések csak az adott feladatra vonatkoznak.
  3. A feladat részletei a bal felső sarokban lévő menüre kattintva érhetők el.

A Feladat menü a következő összetevőket és szolgáltatásokat tartalmazza:

  • név, határidő, nyelv, és a feladat típusa
  • lehetőségek az adott feladat fordításainak letöltésére és feltöltésére
  • az adott feladatból való kilépés lehetősége (“Kilépés a szerkesztőből” gomb) és visszatérés a feladatlistához Feladat menü

Hasznos volt ez a cikk?