Editor Online

Translations are mainly made in the Editor which can be viewed in Comfortable or Side-by-Side mode. Typically Comfortable mode is enabled.

Using the Menu in the top left corner you can switch between files for translations, change translation language, contact manager, switch the view, get help or quit the editor.

Comfortable Mode

Comfortable mode is mainly used for translations and consists of the four main sections:

  1. Left sidebar
  2. Middle-top area
  3. Middle-bottom area
  4. Right sidebar

Editor Sections

Section 1 - Left sidebar

In this section, you will see the list of strings, and the active one will be highlighted. Strings are text elements which are either individual words, expressions, or sentences. Strings are text elements which are either individual words, expressions, or sentences. Some strings might have replacement tokens (something like {0}, {1}, or %1) or elements of ICU message syntax. To work with such strings, you should copy the source string and translate only the real words.

As frases poder ter os seguintes estados:

  • Untranslated - não traduzido
  • Plural forms untranslated - parcialmente traduzido (no caso, algumas das formas plurais não foram traduzidas)
  • Translated - traduzido
  • Plural forms unapproved - parcialmente aprovado (no caso, algumas formas plurais não foram aprovadas)
  • Approved - aprovado
  • Hidden - ocultado (visível apenas para os gestores do projeto e revisores)

There also might be the following icons besides strings:

  • With Comments - the string has comments from contributors
  • With Issue - the string has an unresolved issue

While translating the content of an HTML, XML, TXT, DOCX, HAML, Web XML, and Markdown file formats a list of strings is displayed as a file preview. Statuses of the strings are marked with the following colors:

  • Vermelho - não traduzido
  • Verde claro - traduzido
  • Verde - aprovado
  • Grey - not for translation

Uma frase ativa é destacada com a cor amarela.

HTML view

The following options are available to manage the above view:

  • Basic List View - load basic list view. Use to switch to a standard mode and see a list of strings.
  • Highlight Strings - highlight untranslated, translated, and approved strings. Use to turn on/off color highlight of strings.
  • Translation Preview - show translation preview. Use to turn on/off translations preview mode.

HTML view options

You can search for strings by source text, translations, context, or everything at once. Depending on the content you opened in the Editor, the system will look for matches within the particular opened file or all strings in the project.

To search for strings in the file or the whole project, type your search phrase in the Search in file (Search strings) field. You can also use a keyboard shortcut to switch to the search field (by default, Ctrl+F).

To fine-tune the search results, you can use the following options:

  • Match case – With this option, you will find only the strings written in the same case: for example, if you search for Work and select Match case, the system will find Work, Works, Working but not work.
  • Match whole phrase – With this option, you will find the strings that contain the search phrase only in the original order: for example, if you search for Machine Translation and select Match whole phrase, the system will find Machine Translation, Machine translation, machine translation but not Translation Machine. When Match whole phrase isn’t active, the system splits the search phrase into separate words and searches for matches in the strings in any order.
  • Exact match – With this option, you will find only the strings that exactly match the search phrase: for example, if you search for Work and select Exact match, the system will find Work, work, but not Works or Working.

You can combine Match case with Exact match and Match case with Match whole phrase. Match whole phrase and Exact match are mutually exclusive options.

The search phrase is limited to 128 characters. If you paste a search phrase greater than 128 characters, it will be automatically trimmed down to the maximum allowed limit.

String Search

Filtering Strings

To filter the strings displayed in the left sidebar, click and select the preferred filter option.

Available filter options:

  • Show All – Show all strings from the opened file/folder in the original order.
  • All, Untranslated First – Show all strings from the opened file/folder. Untranslated strings are displayed at the top of the list, then translated strings, and the approved ones are displayed at the bottom of the list.
  • Untranslated – Show only strings without any translations.
  • Need to Be Voted – Show already translated strings.
  • Not Approved – Show strings that are already translated but not yet approved by a proofreader.
  • Approved – Show only strings with approved translations.
  • QA issues – Show strings with no QA issues or with unresolved QA issues in the current language.
  • Machine Translation – Show strings that are translated by TM or MT suggestions without changes. Often such strings need additional review.
  • With Comments – Show strings that have comments.
  • With Unresolved Issues – Show strings with unresolved issues in the current language or all languages.
  • Hidden – Show strings that are hidden from translators. Strings can be hidden by project managers or hidden automatically by Crowdin when they are marked as duplicates.
  • Advanced Filter – Filter that allows configuring own filtering and sorting parameters.

Strings filter

Verbal Expressions

The Verbal Expression section implements a regular expression search. You can set specific search parameters for strings in your project. For example, you can search for all strings that begin with capital letters and have no dots at the end or contain a date.

Note: When you enable verbal expressions, you cannot use regular string search.

For example, if you’d like to extract all strings that start with a capital letter and have a dot at the end, your expression might look like this: start, then "A,Z", anything, range "a,z,A,Z,0,9", limit "1,", then ".", end

Let’s break down the expression above:

start – indicates the beginning of the expression. then "A,Z" – means that your expression starts with characters ranging A-Z. range "a,z,A,Z,0,9" – means that your custom placeholder might include characters ranging a-z and/or A-Z and/or 0-9. limit "1," – means that the length of the expression is from 1 character. then "." – means that your expression ends with a dot. end – indicates the end of the expression.

To configure a verbal expression, use the following expression syntax.

Section 2 - Middle-top area

The main working area with the source string on the top and translation section below. To add a translation, you need to choose the string from the left section, and it will appear in the central top field Source String.

Text for translation

This area also shows the context of a string. Context can include the technical details, an explanation of where the line appears in the actual product or screenshot showing the location of the string in a user interface. If the source string does not have any context, and it isn’t clear how to translate it, click Request and project manager will be notified that additional explanations are required.

Request context

Some strings might have underlined words or expressions. This means the word or expression belongs to the project terminology and should be translated according to the term description. You can check additional explanations added to the specific term for the accurate translation. This can be done by hovering over the underlined text or by going to the Terms section on the right sidebar.

Some terms may have translations to them. Previously translated terms increase project texts consistency. To reuse the term translation, you have to click the underlined term, and its translation will appear in the translation field.

Terminology

Enter the translation into the field under the original text on the central section and click Save. You will be automatically redirected to the next string.

Save translation

Plural Forms

Algumas frases podem conter formas plurais. Depending on the language, the number of plural forms may vary. For example, Chinese has one plural form, English has two plural forms, and other languages might have even up to six plural forms. Crowdin works with plural forms according to CLDR Language Plural Rules.

Read more about CLDR Language Plural Rules.

When a string has multiple plural forms, all variants of the string are shown in the section where you type in translations. Digita as traduções nos separadores correspondentes que representam as formas plurais do idioma de destino.

Plural tabs

You might also get automatic Quality Assurance (QA) check pop-up messages to avoid some translation inaccuracy. For example, you can see notifications about inconsistency in punctuation, space mismatch, missing variables, and more.

QA pop-up

Clicking icon in the top right allows you to:

  • Copy String URL to access specific string using its unique link or share it with colleagues.
  • access Translation History to see all the modifications done to the string. In the translation window, you will also see the Maximum length of translation limit if it’s exceeded.

Section 2

Additional buttons available in the translations section:
Copy Source - Copy Source. Use to keep the initial string structure while translating messages with replacement tokens or elements of ICU message syntax.
Clear Translation - Clear. Use if you need to erase the whole suggestion quickly.
Text selection mode - Text selection mode. Use if you want to copy part of translations from Translation Memory (TM) or Machine Translations (MT).

Section 3 - Middle-bottom area

This section contains the resources that might be useful:

  • Translations by other project participants
  • Translation Memory (TM) suggestions
  • Machine Translation (MT) suggestions
  • Translations to other languages

Click on one of the suggestions, and it will automatically appear in the translation field. Refer to it as a basis for own suggestions.

To quickly copy the TM or MT suggestion to the translation field and save it, click Use and Save icon on the desired suggestion.

Other Languages section allows you to check the string translations into other target languages. This can be a useful tip for multilingual people and while translating dialects of a language.

Other languages

If you see that there is already a correct suggestion, vote for it. To vote for several translations it would be more convenient switching to Side-by-Side Mode.

Vote

If you are a proofreader and plan to review and approve more than one translation — switch to Side-by-Side Mode.

Section 4 - Right sidebar

Comentários

Using the Comments tab, you can discuss the meaning of the source string or other related questions. É recomendado usar o idioma de origem do projeto para que outros tradutores possam entender. Use “@” and username to direct your message to the specific person.

Comentários

Reporting Issues

Additionally, in the Comments tab, you can report the issues regarding the source strings or translations to the project managers by selecting the Issue checkbox.

Available issue types:

  • General question – General question related to the source string or its translations.
  • Current translation is wrong – The translation added to the source string is incorrect and requires correction.
  • Lack of contextual information – The meaning of the string isn’t clear and requires additional clarifications.
  • Mistake in the source string – The source string text contains typos or any other mistakes.

All strings with unresolved issues could be filtered using the With Unresolved Issues options.

Read more about Filtering Strings.

Issue

The issues are reported to the project managers to correct mistakes or add context and resolve the issues. You can also Edit, Resolve, or Delete your issue by hovering over it.

Issue options

If the project owner or managers configured the integration with Jira, all reported issues will be directed to the Jira dashboard for further processing and resolution without the need to visit Crowdin Editor.

Read more about Jira Integration.

Search TM

By going to the Search TM tab, you can check for all the available translations from Translation Memory that is the vault of translations uploaded to the system by project managers.

The Search TM tab provides the following options:

  • Source – Search for matches in a source language.
  • Target – Search for matches in target languages.
  • Guess translation – Highlight probable translation of a search phrase.
  • Numeric equivalence – Match digits from a search phrase with any other digits.

Additionally, to maximize your search results, you can use the following wildcards with your search phrase:

Type an asterisk (*) to find words where the end or beginning may be different. Example: any* finds any, anyway, anything Example: *way finds way, anyway, highway

Type a plus sign (+) to find words where the end or beginning must be different. Example: any+ finds anyway, anything, anywhere, except any Example: +way finds anyway, highway, someway, except way

Type a minus sign (-) to exclude words from your search. Example: Save -as

Use quotation marks to find the exact combination of words. Example: “Save as”

Search TM

Terms

Terms tab can be used to see the existing glossary available for the string (if any). You can also search for the terms in project glossary.  If the specific term is not available in the project’s glossary, the system will show you Wikipedia explanations.

Terms

Side-by-Side Mode

In Side-by-Side mode, translators can also translate, although, this mode is mostly intended for comfortable voting for multiple best translations in a row, while managers and proofreaders can approve the best translations.

To switch to the Side-by-Side mode, open the Menu in the top left corner then choose View > Side-by-Side.

For translators

To vote click on the plus sign if you like the translation, minus - if the translation doesn’t seem correct. Translations that get the most positive votes will then appear on the top of all the translations available for the string.

Side-by-Side Voting

For proofreaders

Review the translations to make sure they are ready for export and click Approve icon next to the suggestion to approve each translation separately.

Para aprovar todas ou algumas frases duma vez só, verifica as caixas na esquerda e depois, clica Aprovar.

Side-by-Side Proofreading

Note: Make sure to enable QA checks to help you find strings that require review. Os problemas encontrados serão destacados em vermelho nas frases traduzidas que requerem revisão.

QA issues

Sugerir Traduções

To suggest another translation сlick on the text you want to change and when done click Save. Your translation will be added to the list of other suggestions.

Save suggestion

Traduzir Idiomas RTL (ex: árabe)

Ao traduzir entre os idiomas LTR e RTL, alguns dos elementos no campo de tradução no Editor podem não ser exibidos na mesma forma que serão exportados uma vez.

To be sure that RTL translations will be displayed correctly in the exported file, we recommend making translations the following way:

  1. Click under the source text (or Alt+C key combination).
  2. Traduz os textos de origem para o idioma de destino.
  3. Leave variables, tags, etc. unchanged in the translation, even if they look wrong. They will be in the right positions in the exported file.

Save suggestion

Definições do Editor

To open the Editor settings, click in the right upper corner.

Settings

As Definições do Editor inclui as seguintes configurações:

  • Translation Memory Suggestions – you can specify the minimum similarity match (in percentages) for translation memory suggestions shown under the translation field.
  • Compact strings view – if enabled only the beginnings of the long strings will be shown in the string list.
  • QA checks – if enabled the pop-up messages with warnings will appear each time you try to save a translation with some inaccuracy (punctuation/tags/spaces mismatch, missing variables etc.)
    Validators

  • Auto-complete – if enabled the pop-up with translation prediction and automatic translation completion will appear while you type the translation.
  • Auto-approve – if enabled the translations added by proofreaders or members with higher permissions are automatically approved.
  • HTML Tags Displaying – you can choose Show or Hide option that applies to all HTML tags. In case you choose Auto tags will be hidden in HTML, Haml, XML, Web XML, Markdown, Docx files but shown in other file formats. Quando as tags estão ocultadas, podes esperar que, por exemplo:
    <a href="https://sample.com">Sample</a>
    

    will be replaced with

    <0>Sample</0>
    
  • Color Theme – set the Light or Dark theme, or select Auto to allow the Editor to set the theme based on your device system settings.
    Settings

Helpful tips

Atalhos do Teclado

Use keyboard shortcuts to take actions in the editor quickly. Most of the hotkeys can be customized to your personal preferences. Check the list of keyboard shortcuts by clicking the keyboard icon in the right upper corner. Click on the necessary key combination, and modify it with the help of your keyboard.

Atalhos do Teclado

Easy access to most-used menu items in one click:

  • Language – click on the current language (French in the below screenshot)
  • Files – click on the current file name (impact.xml in the below screenshot)
    Quick access

Useful options for source words

Para verificar as sugestões da Memória de Tradução para uma palavra ou frase específica, seleciona-a na frase de origem e escolhe a Pesquisar na MT do menu. Também, podes pesquisar por uma explicação de palavra ou frase na terminologia do projeto e Wikipédia.

Note: Create Term option in this section is available for managers only.

Searh term

Mudar para Outro Ficheiro

Para traduzir frases de outros ficheiros, segue estes passos:

  1. Open the Menu or click on the current file name in the top left corner.
  2. Choose File > Open.
    Open file
  3. Seleciona o ficheiro necessário e clica Abrir. Alternatively just double-click on the necessary file.
    Choose file

To see all strings of the project, use the Menu in the top left corner, go to File > All Strings. Alternatively click on the current file name in the top left corner > All Strings.

Substituir nas Traduções Sugeridas

Podes facilmente, encontrar e substituir traduções sugeridas, ao usar o recurso Substituir nas Traduções.

Para alterar as tuas traduções anteriormente, adicionadas para as novas, segue estes passos:

  1. Na página do Projeto seleciona o idioma necessário.
  2. Click All Strings > Translation or choose a file for translation.
  3. Open the Menu in the top left corner.
  4. Go to File > Replace in Translations.
    Replace translations
  5. Insert the word, phrase, or sentence you want to substitute and the text to replace it with.
    Insert text
  6. Clica Pré-Visualizar para encontrar as frases que serão substituídas.
    Preview
  7. Seleciona as traduções que gostarias de substituir e clica Substituir Selecionadas para concluir.

Advanced Filter

You can create a custom filter of strings by clicking the Filter strings icon and choosing Advanced Filter option.
You can choose multiple filter parameters (e.g., strings added, strings updated, translations updated, Labels and more) based on your specific needs to sort the strings. This might help to find the necessary information much faster.

In the below screenshot, you may see the strings are filtered by Translations updated interval, the Labels that the filtered strings should be marked with, the Comments, Visibility, and Approved by parameters as well as sorted by Alphabet in Descending order. Advanced Filter

Hide Context in Side-by-Side Mode

O contexto é mostrado por padrão. Use Info icon to hide context and other information like translation or approval date, suggestion authors. As frases sem qualquer contexto, ocupam menos espaço na tela.

Hide Context

Tasks in the Editor

Once a translator or proofreader has a task assigned, all the task details are accessible from the editor:

  1. Name of the task is displayed on the top of the toolbar.
  2. Filters and searches apply to a particular task only.
  3. Task details can be accessed by clicking the menu on the top left corner.

Task menu consists of the following components and features:

  • name, due date, language, and type of the task
  • options to download and upload translations for the particular task
  • possibility to quit the particular task (“Quit Editor” button) editor and return to the task list Task Menu

Este artigo foi útil?