Плагін Adobe XD

За допомогою плагіну Crowdin для Adobe XD ви можете використовувати тексти з Crowdin Enterprise у своїх проєктах, щоб заощадити час як дизайнерам, так і розробникам. These could include original or translated texts. За потреби ви можете додати нові (наприклад, заголовки діалогів, написи кнопок) і надіслати їх перекладачам у Crowdin Enterprise.

Варіанти використання

  • Quickly generate multilingual creative assets.
  • Перекладіть макети та протестуйте їх різними мовами перед програмуванням.
  • Припиніть використовувати «Lorem Ipsum», натомість додайте реальні тексти від Crowdin Enterprise до своїх прототипів.
  • Створюйте та завантажуйте вихідні рядки зі своїх проєктів у свій проєкт Crowdin Enterprise. This way, uploaded strings could be used by developers, which reduces time spent on development.
  • Завантажте помічені скріншоти до свого проекту Crowdin.

Installing Crowdin plugin for Adobe XD

  1. Sign in to Adobe XD.
  2. Navigate to Plugins > Discover plugins…
  3. Click Browse.
  4. Use the Search Plugins… field to find the Crowdin plugin for Adobe XD.
  5. Click Install.

Підключення Adobe XD до облікового запису Crowdin Enterprise

Налаштування облікових даних Crowdin Enterprise

Щоб вказати свої облікові дані Crowdin Enterprise в Adobe XD, виконайте такі дії:

  1. On the left panel, click Plugins > Crowdin for Adobe XD.
  2. Click .
  3. Вкажіть свій особистий токен доступу.
  4. Вкажіть ім’я домену вашої організації та натисніть Зберегти.
    Adobe XD Plugin Connect to Crowdin Enterprise

Щоб створити новий токен у Crowdin Enterprise, виконайте такі дії:

  • Перейдіть до Налаштування облікового запису > Токени доступу і натисніть Новий токен.
  • Вкажіть Назву токена, виберіть Області та Проєкти, натисніть Створити.

Вибір проєкту Crowdin Enterprise

To select the project you’d like to work with, click the drop-down menu, and select a project from the list. Later on, you can use the same drop-down menu to switch to another project if needed. Adobe XD Plugin Selecting Crowdin Project

Additionally, you can select the specific branch your content will be uploaded to. Adobe XD Plugin Selecting Branch

UI Localization

Use the Strings section when localizing UI and working on dynamic pages with your development and marketing teams. У цьому розділі ви можете одним клацанням миші додати вихідні рядки з Crowdin Enterprise до своїх проєктів в Adobe XD. After the texts are used in the designs, you can automatically upload tagged screenshots for translators’ reference back to Crowdin Enterprise.

Використання вихідних рядків із Crowdin Enterprise в Adobe XD

  1. Open the Crowdin plugin for Adobe XD.
  2. In the Strings section, use the Search field to find the specific copy. You can search strings by both the source text or the string identifier.
  3. Select the text layer you want to add text to and click on the needed string. Плагін Adobe XD з використанням вихідних рядків із Crowdin Enterprise в Adobe XD

Після використання вихідних рядків із Crowdin Enterprise у своїх проєктах ви можете попередньо переглянути переклади для цих рядків у Adobe XD і завантажити знімки екрана для них у свій проєкт Crowdin Enterprise.

Додавання вихідних рядків з Adobe XD до Crowdin Enterprise

You can add the strings that are already used in the designs or create and add completely new strings.

  1. Open the Crowdin plugin for Adobe XD.
  2. To add the strings used in the designs, select the whole artboard, multiple artboards, or the needed strings on the artboards. Alternatively, skip this step if you want to add a new string.
  3. In the Strings section, click .
  4. In the appeared dialog, fill in the required fields.
  5. (Optional) To add labels to the strings, alternately select them from the Label drop-down menu and click Save.
    Adobe XD Plugin Add String

Щоб додати однакові рядки до кількох файлів у Crowdin Enterprise, по черзі виберіть потрібні файли зі спадного меню Файл.

Adobe XD Plugin Add String To Multiple Files

Якщо деякі монтажні області містять приховані елементи, які не слід додавати до Crowdin Enterprise, зніміть опцію Надіслати приховані елементи.

Додані рядки буде перенесено до вашого проєкту Crowdin Enterprise, а також відображено в списку розділу Рядки. You can edit or delete the strings from the same list anytime. Відповідні зміни також буде застосовано до рядків у вашому проєкті Crowdin Enterprise.

Key Naming Pattern Settings

Щоб спростити додавання рядків з Adobe XD до проєкту Crowdin Enterprise, ви можете налаштувати бажаний шаблон іменування ключів для ідентифікаторів вихідних рядків у налаштуваннях плагіну. The Crowdin plugin for Adobe XD will suggest the string identifiers for new strings based on the selected pattern. While adding new source strings, you can always edit the suggested identifier to the preferred look.

To select the key naming pattern, follow these steps:

  1. Open the Crowdin plugin for Adobe XD.
  2. Open the plugin Settings.
  3. In the Key naming pattern section, select the preferred option from the drop-down menu.

Завантаження знімків екрана з тегами в Crowdin Enterprise

  1. Open the Crowdin plugin for Adobe XD.
  2. У розділі Рядки використовуйте тексти з проєкту Crowdin Enterprise у своїх дизайнах. Click to upload screenshots of the artboards that include the used texts.
  3. Щоб оновити знімки екрана на Crowdin Enterprise, знову натисніть .

To learn more, read the article Screenshots.

Previewing Strings

Попередній перегляд перекладів із Crowdin Enterprise для рядків, які використовуються в дизайнах в Adobe XD. You can preview translations in the new frames or the original ones. When previewing translations in the new frames, you can populate them with the actual translations or with string keys for further use by developers.

To preview strings populated with translations, follow these steps:

  1. Open the Crowdin plugin for Adobe XD.
  2. In the Strings > Preview Strings section, select Preview in duplicated artboards or Preview in the current artboards.
  3. Select Create with language.
  4. Select the target language you want to preview translations for. Ви також можете обрати Усі мови.
  5. Choose the content you want to preview in Adobe XD. Select All Artboards or Selected Artboards. Adobe XD Plugin Preview Strings

To preview strings populated with key names, follow these steps:

  1. Open the Crowdin plugin for Adobe XD.
  2. In the Strings > Preview Strings section, select Preview in duplicated artboards.
  3. Select Create with key names.
  4. Choose the content you want to preview in Adobe XD. Select All Artboards or Selected Artboards.
    Adobe XD Plugin Preview Keys

Marketing Visuals Localization

Use the Translation section to localize static pages, like brochures and banners. У цьому розділі ви можете надсилати тексти з контекстом для перекладачів до Crowdin Enterprise і завантажувати перекладені копії назад до Adobe XD.

Надсилання текстів для перекладу в Crowdin Enterprise

You can send text for translation either from selected or all artboards from an Adobe XD file. Translators will work with those texts in the list view and use designs as an additional context for even higher translation quality.

У Crowdin Enterprise буде створено кореневу теку Plugin Adobe XD. It will contain a subfolder named after your XD file with HTML files for each artboard inside. This folder can also contain a free-text.html file with texts not included in any of the artboards. If needed, you can disable content segmentation in the plugin Settings so the long texts will not be split into sentences.

To send Adobe XD designs for translation, follow these steps:

  1. Open the necessary Adobe XD file.
  2. Go to Plugins > Crowdin for Adobe XD.
  3. In the Translation > Send texts to Crowdin section, select content you’d like to translate. Select All Artboards or Selected Artboards. Adobe XD Plugin Send Texts

Коли вихідні файли будуть завантажені у ваш проєкт Crowdin Enterprise, ви можете запросити співавторів перекласти та перевірити їх.

Докладніше про стратегії перекладу.

Завантаження перекладів із Crowdin Enterprise в Adobe XD

Ви можете синхронізувати тексти між проєктами Adobe XD і Crowdin Enterprise, коли захочете перевірити перекладену копію в Adobe XD або створити багатомовні ресурси.

To upload translated copies to Adobe XD, follow these steps:

  1. Open the necessary Adobe XD file.
  2. Go to Plugins > Crowdin for Adobe XD.
  3. In the Translation > Get translations from Crowdin section, select the target language you want to upload translations for. You can also select All languages.
  4. Select the content you want to preview in Adobe XD. Select All Artboards or Selected Artboards.
    Adobe XD Plugin Get Translations

After uploading translations to Adobe XD, the modified file will contain a separate artboard with translations for each target language. Нещодавно завантажені перекладені версії не замінять версії, які ви завантажили раніше. Ви завжди можете видалити перекладені копії, які більше не потрібні.
Adobe XD Plugin Uploaded Translations

If you’d like the newly uploaded translated versions to override the previously uploaded ones, open the plugin Settings and select Override existing translations.

Ця стаття була корисною?