Plugin per Android Studio

Questo plugin ti consente di integrare il tuo progetto in Android Studio con Crowdin Imprese. Carica le nuove stringhe sorgente e le traduzioni esistenti istantaneamente nel sistema, allo stesso modo di come scarichi le traduzioni dal tuo progetto di Crowdin Imprese.

Configurazione

  1. Install the plugin via JetBrains Plugin repository.
  2. create a file with project credentials named crowdin.properties in the root directory of the project.
project-id=your-project-id api-token=personal-access-token base-url=https://{organization-name}.crowdin.com

Source Files and Translations

Il plugin troverà automaticamente il file strings.xml nella cartella dei valori e, se aggiornate, le modifiche saranno istantaneamente caricate a Crowdin Imprese. If you have more source files or the source file name differs from the default strings.xml, specify it in the sources parameter.

sources=file1.xml, file2.xml

By default, translations are exported to the Resources folder (**/resources/values-uk/strings.xml, **/resources/values-fr/strings.xml, …)

To set up your own source and translation pattern, use the following configuration in the crowdin.properties file:

files.source=/values/*.xml files.translation=/values-%android_code%/%original_file_name%

files.1.source=/another/path/*.xml files.1.translation=/another/path-%android_code%/%original_file_name%

Leggi di più sui Segnaposto per inserire le variabili appropriate.

Note: Currently, %original_path% placeholder is not supported.

Additional Options

Per i progetti di Android Studio che usano un VCS di git, il plugin creerà automaticamente i rami corrispondenti in Crowdin Imprese. Se non usi la funzionalità dei rami in Crowdin Imprese, aggiungi il parametro disable-branches=true nel file di configurazione.

disable-branches=true

Aggiungi auto-upload=false per prevenire il caricamento automatico dei file a Crowdin Imprese.

auto-upload=false

Uso

Per caricare i file sorgente a Crowdin Imprese manualmente, usa il menu Strumenti > Crowdin > Carica Sorgenti o clicca il tasto destro del mouse sul file e seleziona Carica a Crowdin.

To upload existing translations, use the menu Tools > Crowdin > Upload Translations.

Per scaricare le traduzioni da Crowdin Imprese, usa il menu Strumenti > Crowdin > Scarica Traduzioni.

Questo articolo è stato utile?