Beépülő modul az Android Studio-hoz

This plugin lets you integrate your project in Android Studio with Crowdin Enterprise. Töltsön fel azonnal új forrás-karakterláncokat és meglévő fordításokat a rendszerbe, és töltse le a fordításokat a Crowdin Enterprise projektjéből.

Beállítás

  1. Telepítse a beépülőt a JetBrains Plugin adattárból.
  2. hozzon létre egy crowdin.properties nevű fájlt a projekt hitelesítő adataival a projekt gyökérkönyvtárában.
project-id=your-project-id api-token=personal-access-token base-url=https://{organization-name}.crowdin.com

Forrásfájlok és fordítások

A beépülő automatikusan megtalálja a strings.xml fájlt az értékkönyvtárban, és ha frissíti, a módosítások azonnal feltöltésre kerülnek a Crowdinba. Ha több forrásfájlja van, vagy a forrásfájl neve eltér az alapértelmezett strings.xml névtől, akkor adja meg azt a sources paraméterben.

sources=file1.xml, file2.xml

Alapértelmezés szerint a fordítások a Resources mappába kerülnek exportálásra (**/resources/values-uk/strings.xml, **/resources/values-fr/strings.xml, …)

Saját forrás- és fordítási mintáinak beállításához használja a következő konfigurációt a crowdin.properties fájlban:

files.source=/values/*.xml files.translation=/values-%android_code%/%original_file_name%

files.1.source=/another/path/*.xml files.1.translation=/another/path-%android_code%/%original_file_name%

Tudjon meg többet a Helyőrzőkről a megfelelő változók használatához.

Megjegyzés: Jelenleg az %original_path% helyőrző nem támogatott.

Kiegészítő lehetőségek

For Android Studio projects that use a git VCS, the plugin will automatically create corresponding branches in Crowdin Enterprise. If you do not use branches feature in Crowdin Enterprise, add disable-branches=true parameter into the configuration file.

disable-branches=true

Add auto-upload=false to prevent automatic file upload to Crowdin Enterprise.

auto-upload=false

Használat

To upload source files to Crowdin Enterprise manually, use the menu Tools > Crowdin > Upload Sources or click the right mouse button on the file and select Upload to Crowdin.

A meglévő fordítások feltöltéséhez használja az Eszközök > Crowdin > Fordítások feltöltése menüt.

To download translations from Crowdin Enterprise, use the menu Tools > Crowdin > Download Translations.

Hasznos volt ez a cikk?