Plugin for Android Studio

Dette plugin gør det muligt at integrere projektet i Android Studio med Enterprise. Upload straks nye kildestrenge og eksisterende oversættelser til systemet samt download oversættelser fra dit Enterprise-projektet.

Opsætning

  1. Install the plugin via JetBrains Plugin repository.
  2. create a file with project credentials named crowdin.properties in the root directory of the project.
project-id=your-project-id api-token=personal-access-token base-url=https://{organization-name}.crowdin.com

Source Files and Translations

Plugin’et finder automatisk filen strings.xml i værdimappen, og opdateres den, vil den straks blive uploadet til Enterprise. If you have more source files or the source file name differs from the default strings.xml, specify it in the sources parameter.

sources=file1.xml, file2.xml

By default, translations are exported to the Resources folder (**/resources/values-uk/strings.xml, **/resources/values-fr/strings.xml, …)

To set up your own source and translation pattern, use the following configuration in the crowdin.properties file:

files.source=/values/*.xml files.translation=/values-%android_code%/%original_file_name%

files.1.source=/another/path/*.xml files.1.translation=/another/path-%android_code%/%original_file_name%

Læs mere om Variabler for at indsætte de relevante variabler.

Note: Currently, %original_path% placeholder is not supported.

Additional Options

Til Android Studio-projekter, som benytter en git-VCS, opretter plugin’et automatisk korresponderende grene i Enterprise. Benyttes ikke grenfunktioner i Enterprise, så tilføj parameteren disable-branches=true i opsætningsfilen.

disable-branches=true

Tilføj auto-upload=false for at forhindre automatisk filoploading til Enterprise.

auto-upload=false

Afbenyttelse

Upload af kildefiler til Enterprise kan ske via menuen Værktøjer > Crowdin > Upload kilder eller med at højreklik på filen og vælge Upload til Crowdin.

To upload existing translations, use the menu Tools > Crowdin > Upload Translations.

Download af oversættelser kan ske via menuen Værktøjer > Crowdin > Download oversættelser.

Var denne artikel nyttig?