Plugin para Android Studio

Este plug-in permite integrar seu projeto no Android Studio com o Crowdin. Carregue instantaneamente novos textos de origem e traduções existentes no sistema, bem como baixe traduções do seu projeto Crowdin.

Configuração

  1. Instala o plugin através do repositório de Plugin do JetBrains.
  2. crie um arquivo com as credenciais de projeto nomeadas de crowdin.properties no diretório-raiz do projeto.
project-id=seu-projeto-id api-token=pessoal-access-token

Arquivos de origem e tradução

O plugin encontrará o arquivo automaticamente strings.xml no diretório de valores e, se forem atualizadas, as alterações serão carregadas no Crowdin instantaneamente. Se você tiver mais arquivos de origem ou o nome do arquivo de origem for diferente do padrão strings.xml, especifique-o no parâmetro sources.

sources=arquivo1.xml, arquivo2.xml

Por padrão, as traduções são exportadas para a pasta Resources (**/resources/values-uk/strings.xml, **/resources/values-fr/strings.xml, …)

Para configurar seu próprio padrão de origem e tradução, use a seguinte configuração no arquivo crowdin.properties:

files.source=/values/*.xml files.translation=/values-%android_code%/%original_file_name%

files.1.source=/another/path/*.xml files.1.translation=/another/path-%android_code%/%original_file_name%

Leia mais sobre os Marcadores para colocar as variáveis adequadas.

Nota: Atualmente, %original_path% placeholder não é suportado.

Opções adicionais

Para projetos de Android Studio que usam um git VCS, o plugin criará, automaticamente, ramos correspondentes no Crowdin. Se não usa o recurso de ramificações no Crowdin, adiciona o parâmetro desativar-branches=true no arquivo de configuração.

disable-branches=true

Adicione auto-upload=false para prevenir envio automático de arquivos para o Crowdin.

auto-upload=false

Uso

Para carregar arquivos de origem para o Crowdin manualmente, use o menu Ferramentas > Crowdin > Carregar fontes ouclique no botão direito do mouse no arquivo e selecione Carregar para Crowdin.

Para carregar traduções existentes, use o menu Tools > Crowdin > Carregar traduções.

Para baixar traduções do Crowdin, use o menu Ferramentas > Crowdin > Baixar traduções.

Notas

  1. Para versões 0.5.x veja a ramificação 0.5.x. Observe que essas versões não são mais suportadas.
  2. Migração da versão 0.5.x para 1.x.x requer alterações no seu arquivo crowdin.properties.

Este artigo foi útil?